diff mbox series

[bug#41027,core-updates] gnu: python-s3transfer: Fix build with Python 3.8.

Message ID 20200502144441.1489-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#41027,core-updates] gnu: python-s3transfer: Fix build with Python 3.8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines May 2, 2020, 2:44 p.m. UTC
* gnu/packages/python-web.scm (python-s3transfer)[arguments]: Add a 'patch
phase to fix a test to work under Python 3.8.
---
 gnu/packages/python-web.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

Comments

Christopher Baines May 13, 2020, 6:10 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/python-web.scm (python-s3transfer)[arguments]: Add a 'patch
> phase to fix a test to work under Python 3.8.
> ---
>  gnu/packages/python-web.scm | 9 +++++++++
>  1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 27749246d8..56887ef9d4 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -2204,6 +2204,15 @@ Betamax.")
>      (arguments
>       `(#:phases
>         (modify-phases %standard-phases
> +         (add-after 'unpack 'patch
> +           (lambda _
> +             ;; There's a small issue with one test with Python 3.8, this
> +             ;; change has been suggested upstream:
> +             ;; https://github.com/boto/s3transfer/pull/164
> +             (substitute* "tests/unit/test_s3transfer.py"
> +               (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
> +                "futures.Future()"))
> +             #t))
>           (replace 'check
>             (lambda _
>               ;; Some of the 'integration' tests require network access or

I pushed this as c63bd847816061e76389e93dc094df98800f081b back on the
4th of May, but forgot to close the bug.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 27749246d8..56887ef9d4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2204,6 +2204,15 @@  Betamax.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             ;; There's a small issue with one test with Python 3.8, this
+             ;; change has been suggested upstream:
+             ;; https://github.com/boto/s3transfer/pull/164
+             (substitute* "tests/unit/test_s3transfer.py"
+               (("super\\(FailedDownloadParts, self\\)\\.submit\\(function\\)")
+                "futures.Future()"))
+             #t))
          (replace 'check
            (lambda _
              ;; Some of the 'integration' tests require network access or