diff mbox series

[bug#41024] gnu: tmux: Update to 3.1.b.

Message ID 20200502125143.3594-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#41024] gnu: tmux: Update to 3.1.b. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire May 2, 2020, 12:51 p.m. UTC
* gnu/packages/tmux.scm (tmux)[version]: Update to 3.1.b.
[source]: Fetch from git instead of a tarball.
[native-inputs]: Add 'autoconf', 'automake', 'bison' and 'pkg-config'.
---
 gnu/packages/tmux.scm | 27 ++++++++++++++++++---------
 1 file changed, 18 insertions(+), 9 deletions(-)

Comments

ashish.is--- via Guix-patches" via May 2, 2020, 1:32 p.m. UTC | #1
Brice,

Brice Waegeneire 写道:
> * gnu/packages/tmux.scm (tmux)[version]: Update to 3.1.b.

You can drop [version] here.

We treat the version + hash bump as a package-level operation to 
avoid noise like ‘[source]: Update SHA256.’ every time. 
Explicitly listing non-routine changes is correct:

> [source]: Fetch from git instead of a tarball.
> [native-inputs]: Add 'autoconf', 'automake', 'bison' and 
> 'pkg-config'.

> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/tmux/tmux.git")
> +                    (commit version)))
> +              (sha256
> +               (base32
> + 
> "0d8c7f1v75khgq06hlmhsxlxl7jf0mf767aw0makhqg8mxana8by"))))

I'd add a comment to revert to the (hopefully…) bootstrapped 3.2 
tarball when it lands so these new native-inputs and module 
imports can be removed.

When migrating to GIT-FETCH, add a

  (file-name (git-file-name name version))

to the end to turn

  $ guix build --source tmux
  /gnu/store/xndh3x1qj0b59bxg6za0bcllnxvk2wpl-git-checkout

into

  $ guix build --source tmux
  /gnu/store/ns97s45k3qv6vjw3p5xh9bz0bqg1dhia-tmux-3.1b-checkout

purely for humans' sake.

OK with these changes.  Thanks!

Kind regards,

T G-R
Brice Waegeneire May 6, 2020, 9:56 a.m. UTC | #2
Pushed as 80e0e112aca8591045d91605271a3e0a8686f18a without changing to 
git-fetch since a bootstrapped binary is now available.
diff mbox series

Patch

diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 6d536131a7..6ac2fc53f0 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,27 +31,35 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages libevent)
-  #:use-module (gnu packages ncurses))
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages pkg-config))
 
 
 (define-public tmux
   (package
     (name "tmux")
-    (version "3.0a")
+    (version "3.1b")
     (source (origin
-             (method url-fetch)
-             (uri (string-append
-                    "https://github.com/tmux/tmux/releases/download/"
-                    version "/tmux-" version ".tar.gz"))
-             (sha256
-              (base32
-               "1fcdbw77nz918f7gqc1ga7zlkp1g112in1h8kkjnkadgnhldzlaa"))))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tmux/tmux.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "0d8c7f1v75khgq06hlmhsxlxl7jf0mf767aw0makhqg8mxana8by"))))
     (build-system gnu-build-system)
     (inputs
      `(("libevent" ,libevent)
        ("ncurses" ,ncurses)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("bison" ,bison)
+       ("pkg-config" ,pkg-config)))
     (home-page "https://tmux.github.io/")
     (synopsis "Terminal multiplexer")
     (description