diff mbox series

[bug#40994] patch#40994 Programs With Movie Titles (PWMT)

Message ID 20200502120901.36d80711.raghavgururajan@disroot.org
State Superseded
Headers show
Series [bug#40994] patch#40994 Programs With Movie Titles (PWMT) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan May 2, 2020, 4:09 p.m. UTC
Hi Brice!

> I don't see a patch related to jumanji, is it voluntary?

I tried packaging Jumanji, but it is ported to new versions of webkitgtk. We do
not have older versions of webkitgtk in guix.

> Could you take example on a commit like
> aff0cce9175aaf836dd78941eb17549e3bfa7188 (there must be others like it)
> which move packages to a separate module. In particular create a commit
> that just move the packages in the new module and adjust the modules 
> that
> depend on them (if any). Then add your modifications to the packages in
> separate commits to the one moving them with the git messages correctly
> formatted, ie. not in a free form style. Otherwise it's difficult to
> understand what your package modifications are related to just moving 
> them
> elsewhere,since it's just a big diff.

Thanks for the feedback. Sure thing!

Please find the attachments with this email, for moving stuffs. All the moved
packages only refer to each other. So no need of altering any other package
definitions.

I will send another set of patches for modifying stuffs,

Thank you!

Regards,
RG.

Comments

Marius Bakke May 6, 2020, 7:29 p.m. UTC | #1
Hi Raghav,

Raghav Gururajan <raghavgururajan@disroot.org> writes:

> Please find the attachments with this email, for moving stuffs. All the moved
> packages only refer to each other. So no need of altering any other package
> definitions.

I'm not convinced that moving these packages are worth the effort,
though I'm not opposed to it either.  What is the rationale?

I do have a few nits to pick though :-)

> From a05c5d174a9ee40e433a64c50f19c7f106381903 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sat, 2 May 2020 11:16:04 -0400
> Subject: [PATCH 1/7] gnu: Move girara from gtk.scm to pwmt.scm.
>
> * gnu/packages/gtk.scm (girara): Move to [...]
> * gnu/packages/pwmt.scm (girara): [...] here.
> ---
>  gnu/packages/gtk.scm  | 49 -----------------------
>  gnu/packages/pwmt.scm | 91 +++++++++++++++++++++++++++++++++++++++++++
>  2 files changed, 91 insertions(+), 49 deletions(-)
>  create mode 100644 gnu/packages/pwmt.scm
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index bea4850d15..4d093a0e0a 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1445,55 +1445,6 @@ In addition to the low level layout rendering routines, Pango includes
>  and routines to assist in editing internationalized text.")
>      (license license:lgpl2.1+)))
>  
> -(define-public girara
> -  (package
> -    (name "girara")
> -    (version "0.3.4")
> -    (source
> -     (origin
> -       (method git-fetch)
> -       (uri (git-reference
> -             (url "https://git.pwmt.org/pwmt/girara")
> -             (commit version)))
> -       (file-name (git-file-name name version))
> -       (sha256
> -        (base32 "08rpw9hkaprm4r853xy1d35i2af1pji8c3mzzl01mmwmyr9p0x8k"))))
> -    (native-inputs `(("pkg-config" ,pkg-config)
> -                     ("check" ,check)
> -                     ("gettext" ,gettext-minimal)
> -                     ("glib:bin" ,glib "bin")
> -                     ("xorg-server" ,xorg-server-for-tests)))
> -    ;; Listed in 'Requires.private' of 'girara.pc'.
> -    (propagated-inputs `(("gtk+" ,gtk+)))
> -    (arguments
> -     `(#:phases (modify-phases %standard-phases
> -                  (add-before 'check 'start-xserver
> -                    ;; Tests require a running X server.
> -                    (lambda* (#:key inputs #:allow-other-keys)
> -                      (let ((xorg-server (assoc-ref inputs "xorg-server"))
> -                            (display ":1"))
> -                        (setenv "DISPLAY" display)
> -
> -                        ;; On busy machines, tests may take longer than
> -                        ;; the default of four seconds.
> -                        (setenv "CK_DEFAULT_TIMEOUT" "20")
> -
> -                        ;; Don't fail due to missing '/etc/machine-id'.
> -                        (setenv "DBUS_FATAL_WARNINGS" "0")
> -                        (zero? (system (string-append xorg-server "/bin/Xvfb "
> -                                                      display " &")))))))))
> -    (build-system meson-build-system)
> -    (home-page "https://pwmt.org/projects/girara/")
> -    (synopsis "Library for minimalistic gtk+3 user interfaces")
> -    (description "Girara is a library that implements a user interface that
> -focuses on simplicity and minimalism.  Currently based on GTK+, a
> -cross-platform widget toolkit, it provides an interface that focuses on three
> -main components: a so-called view widget that represents the actual
> -application, an input bar that is used to execute commands of the
> -application and the status bar which provides the user with current
> -information.")
> -    (license license:zlib)))
> -
>  (define-public gtk-doc
>    (package
>      (name "gtk-doc")
> diff --git a/gnu/packages/pwmt.scm b/gnu/packages/pwmt.scm
> new file mode 100644
> index 0000000000..8185cc40d9
> --- /dev/null
> +++ b/gnu/packages/pwmt.scm
> @@ -0,0 +1,91 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;;
> +;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
> +;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
> +;;; Copyright © 2017 2018 Marius Bakke <mbakke@fastmail.com>
> +;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
> +;;; Copyright © 2018 2019 2020 Tobias Geerinckx-Rice <me@tobias.gr>
> +;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>

For each patch, please include the copyright information for that
package only.  I don't think all of these people worked on girara.

That makes it easier to track when someone decides to move these
packages to gtk.scm and pdf.scm in the future.  ;-)

> +(define-module (gnu packages pwmt)
> +  #:use-module (gnu packages)
> +  #:use-module (gnu packages check)
> +  #:use-module (gnu packages documentation)
> +  #:use-module (gnu packages gettext)
> +  #:use-module (gnu packages glib)
> +  #:use-module (gnu packages gnome)
> +  #:use-module (gnu packages gtk)
> +  #:use-module (gnu packages pkg-config)
> +  #:use-module (gnu packages web)
> +  #:use-module (gnu packages xorg)
> +  #:use-module (gnu packages xdisorg)

Likewise for modules: gnome, web, xorg and xdisorg seems unused for
girara. 

> +  #:use-module ((guix licenses) #:prefix license:)
> +  #:use-module (guix packages)
> +  #:use-module (guix download)

And (guix download).

> +  #:use-module (guix git-download)
> +  #:use-module (guix build-system gnu)

And gnu-build-system.

> +  #:use-module (guix build-system meson))
> +
> +(define-public girara
> +  (package
> +    (name "girara")
> +    (version "0.3.4")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.pwmt.org/pwmt/girara")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "08rpw9hkaprm4r853xy1d35i2af1pji8c3mzzl01mmwmyr9p0x8k"))))
> +    (native-inputs `(("pkg-config" ,pkg-config)
> +                     ("check" ,check)
> +                     ("gettext" ,gettext-minimal)
> +                     ("glib:bin" ,glib "bin")
> +                     ("xorg-server" ,xorg-server-for-tests)))
> +    ;; Listed in 'Requires.private' of 'girara.pc'.
> +    (propagated-inputs `(("gtk+" ,gtk+)))
> +    (arguments
> +     `(#:phases (modify-phases %standard-phases
> +                  (add-before 'check 'start-xserver
> +                    ;; Tests require a running X server.
> +                    (lambda* (#:key inputs #:allow-other-keys)
> +                      (let ((xorg-server (assoc-ref inputs "xorg-server"))
> +                            (display ":1"))
> +                        (setenv "DISPLAY" display)
> +
> +                        ;; On busy machines, tests may take longer than
> +                        ;; the default of four seconds.
> +                        (setenv "CK_DEFAULT_TIMEOUT" "20")
> +
> +                        ;; Don't fail due to missing '/etc/machine-id'.
> +                        (setenv "DBUS_FATAL_WARNINGS" "0")
> +                        (zero? (system (string-append xorg-server "/bin/Xvfb "
> +                                                      display " &")))))))))
> +    (build-system meson-build-system)
> +    (home-page "https://pwmt.org/projects/girara/")
> +    (synopsis "Library for minimalistic gtk+3 user interfaces")
> +    (description "Girara is a library that implements a user interface that
> +focuses on simplicity and minimalism.  Currently based on GTK+, a
> +cross-platform widget toolkit, it provides an interface that focuses on three
> +main components: a so-called view widget that represents the actual
> +application, an input bar that is used to execute commands of the
> +application and the status bar which provides the user with current
> +information.")
> +    (license license:zlib)))
> \ No newline at end of file

Also make sure that the files end with a newline, like all other files
in Guix.

For the remainder in this series, please also check whether module
imports can be removed from pdf.scm (that makes it worth it IMO).
Raghav Gururajan May 8, 2020, 3:28 a.m. UTC | #2
Hi Marius!

> I'm not convinced that moving these packages are worth the effort,
> though I'm not opposed to it either.  What is the rationale?

The idea is to put together the packages of PWMT project. The concept is
similar to suckless.scm.

> For each patch, please include the copyright information for that
> package only.  I don't think all of these people worked on girara.

Yes, they have. I checked with git log. :-)

> Likewise for modules: gnome, web, xorg and xdisorg seems unused for
> girara. 
>
> And (guix download).
> 
> And gnu-build-system.
> 
> Also make sure that the files end with a newline, like all other files
> in Guix.

I have made these changes and sent updated patch to the thread.

Regards,
RG.
diff mbox series

Patch

From a9f155ad914c4f83a8d4220249d3cbf4fab096ac Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 2 May 2020 12:01:58 -0400
Subject: [PATCH 7/7] gnu: Move zathura-cb from pdf.scm to pwmt.scm.

* gnu/packages/pdf.scm (zathura-cb): Move to [...]
* gnu/packages/pwmt.scm (zathura-cb): [...] here.
---
 gnu/packages/pdf.scm  | 35 -----------------------------------
 gnu/packages/pwmt.scm | 36 ++++++++++++++++++++++++++++++++++++
 2 files changed, 36 insertions(+), 35 deletions(-)

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 6949ca4750..caae864979 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -391,41 +391,6 @@  reading and editing of existing PDF files.")
    (license license:gpl3)             ; or gpl2, but not gpl2+
    (home-page "https://www.xpdfreader.com/")))
 
-(define-public zathura-cb
-  (package
-    (name "zathura-cb")
-    (version "0.1.8")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://pwmt.org/projects/zathura-cb/download/zathura-cb-"
-                              version ".tar.xz"))
-              (sha256
-               (base32
-                "1i6cf0vks501cggwvfsl6qb7mdaf3sszdymphimfvnspw810faj5"))))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (inputs `(("libarchive" ,libarchive)
-              ("zathura" ,zathura)))
-    (build-system meson-build-system)
-    (arguments
-     `(#:tests? #f                      ; package does not contain tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-plugin-directory
-           ;; Something of a regression in 0.1.8: the new Meson build system
-           ;; now hard-codes an incorrect plugin directory.  Fix it.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("(install_dir:).*" _ key)
-                (string-append key
-                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
-             #t)))))
-    (home-page "https://pwmt.org/projects/zathura-cb/")
-    (synopsis "Comic book support for zathura (libarchive backend)")
-    (description "The zathura-cb plugin adds comic book support to zathura
-using libarchive.")
-    (license license:zlib)))
-
 (define-public podofo
   (package
     (name "podofo")
diff --git a/gnu/packages/pwmt.scm b/gnu/packages/pwmt.scm
index 1662ee6d45..2516c62485 100644
--- a/gnu/packages/pwmt.scm
+++ b/gnu/packages/pwmt.scm
@@ -24,6 +24,7 @@ 
 
 (define-module (gnu packages pwmt)
   #:use-module (gnu packages)
+  #:use-module (gnu packages backup)
   #:use-module (gnu packages check)
   #:use-module (gnu packages djvu)
   #:use-module (gnu packages documentation)
@@ -305,4 +306,39 @@  by using the @code{mupdf} rendering library.")
     (synopsis "DjVu support for zathura (DjVuLibre backend)")
     (description "The zathura-djvu plugin adds DjVu support to zathura
 using the DjVuLibre library.")
+    (license license:zlib)))
+
+(define-public zathura-cb
+  (package
+    (name "zathura-cb")
+    (version "0.1.8")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://pwmt.org/projects/zathura-cb/download/zathura-cb-"
+                              version ".tar.xz"))
+              (sha256
+               (base32
+                "1i6cf0vks501cggwvfsl6qb7mdaf3sszdymphimfvnspw810faj5"))))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("libarchive" ,libarchive)
+              ("zathura" ,zathura)))
+    (build-system meson-build-system)
+    (arguments
+     `(#:tests? #f                      ; package does not contain tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-plugin-directory
+           ;; Something of a regression in 0.1.8: the new Meson build system
+           ;; now hard-codes an incorrect plugin directory.  Fix it.
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "meson.build"
+               (("(install_dir:).*" _ key)
+                (string-append key
+                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
+             #t)))))
+    (home-page "https://pwmt.org/projects/zathura-cb/")
+    (synopsis "Comic book support for zathura (libarchive backend)")
+    (description "The zathura-cb plugin adds comic book support to zathura
+using libarchive.")
     (license license:zlib)))
\ No newline at end of file
-- 
2.26.2