diff mbox series

[bug#40994] 6-zathura-djvu-v1

Message ID 20200502051607.31a204b3.raghavgururajan@disroot.org
State Superseded
Headers show
Series [bug#40994] 6-zathura-djvu-v1 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan May 2, 2020, 9:16 a.m. UTC

diff mbox series

Patch

From e2dde54a224777bcb2b050cb828db1a9fe6da532 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 2 May 2020 05:12:02 -0400
Subject: [PATCH 6/6] gnu: zathura-djvu: Move to pwmt module.

Moved variable from pdf.scm to pwmt.scm, for being part of pwmt project.
Added extra dependencies and arguments for additional features.
Removed phase 'patch-plugin-directory'.
Added configure-flag 'plugindir'.
Updated synopsis and description.
Made some cosmetic changes in the definition.

* gnu/packages/pdf.scm (zathura-djvu): Remove variable.
* gnu/packages/pwmt.scm (zathura-djvu): Add variable.
---
 gnu/packages/pdf.scm  | 36 ------------------------------------
 gnu/packages/pwmt.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 2 files changed, 40 insertions(+), 36 deletions(-)

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 30a8ec20e6..6949ca4750 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -426,42 +426,6 @@  reading and editing of existing PDF files.")
 using libarchive.")
     (license license:zlib)))
 
-(define-public zathura-djvu
-  (package
-    (name "zathura-djvu")
-    (version "0.2.9")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://pwmt.org/projects/zathura-djvu/download/zathura-djvu-"
-                              version ".tar.xz"))
-              (sha256
-               (base32
-                "0062n236414db7q7pnn3ccg5111ghxj3407pn9ri08skxskgirln"))))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (inputs
-     `(("djvulibre" ,djvulibre)
-       ("zathura" ,zathura)))
-    (build-system meson-build-system)
-    (arguments
-     `(#:tests? #f                      ; package does not contain tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-plugin-directory
-           ;; Something of a regression in 0.2.8: the new Meson build system
-           ;; now hard-codes an incorrect plugin directory.  Fix it.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("(install_dir:).*" _ key)
-                (string-append key
-                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
-             #t)))))
-    (home-page "https://pwmt.org/projects/zathura-djvu/")
-    (synopsis "DjVu support for zathura (DjVuLibre backend)")
-    (description "The zathura-djvu plugin adds DjVu support to zathura
-using the DjVuLibre library.")
-    (license license:zlib)))
-
 (define-public podofo
   (package
     (name "podofo")
diff --git a/gnu/packages/pwmt.scm b/gnu/packages/pwmt.scm
index c2c53ca8ec..173a35d892 100644
--- a/gnu/packages/pwmt.scm
+++ b/gnu/packages/pwmt.scm
@@ -25,6 +25,7 @@ 
 (define-module (gnu packages pwmt)
   #:use-module (gnu packages)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages djvu)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages file)
   #:use-module (gnu packages freedesktop)
@@ -317,3 +318,42 @@  using the poppler rendering library.")
 using the mupdf rendering library.")
     (home-page "https://pwmt.org/projects/zathura-pdf-mupdf/")
     (license license:zlib)))
+
+(define-public zathura-djvu
+  (package
+    (name "zathura-djvu")
+    (version "0.2.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://pwmt.org/projects/" name "/download/"
+                       name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0062n236414db7q7pnn3ccg5111ghxj3407pn9ri08skxskgirln"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:tests? #f                      ; No target
+       #:glib-or-gtk? #t                ; To compile schemas
+       #:configure-flags
+       (list
+        (string-append "-Dplugindir="
+                       (assoc-ref %outputs "out") "/lib/zathura"))))
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cairo" ,cairo)
+       ("djvulibre" ,djvulibre)
+       ("girara" ,girara)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("json-c" ,json-c)          ; For configuration dumping support
+       ("libnotify" ,libnotify)    ; For notification support
+       ("zathura" ,zathura)))
+    (synopsis "DjVu support for zathura")
+    (description "The zathura-djvu plugin adds DjVu support to zathura
+using the DjVu library.")
+    (home-page "https://pwmt.org/projects/zathura-djvu/")
+    (license license:zlib)))
-- 
2.26.2