diff mbox series

[bug#40996,1/3] gnu: Add pegtl.

Message ID 20200501130930.5888-1-brice@waegenei.re
State Accepted
Headers show
Series Fix usbguard's warning about 'catch'. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire May 1, 2020, 1:09 p.m. UTC
* gnu/packages/cpp.scm (pegtl): New variable.
---
 gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ludovic Courtès May 4, 2020, 8:13 p.m. UTC | #1
Hi!

Brice Waegeneire <brice@waegenei.re> skribis:

> * gnu/packages/cpp.scm (pegtl): New variable.

[...]

> +(define-public pegtl
> +    (package
      ^
Indentation is off.

> +      (synopsis "Parsing Expression Grammar Template Library")

I’d remove at least the capital T and L.  :-)

Otherwise LGTM!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 2248ebfc4b..cdc1c0e0f4 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -485,3 +486,24 @@  point and then, after each tween step, plugging back the result.")
 augment the C++ standard library.  The Abseil library code is collected from
 Google's C++ code base.")
     (license license:asl2.0)))
+
+(define-public pegtl
+    (package
+      (name "pegtl")
+      (version "2.8.3")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/taocpp/PEGTL.git")
+                      (commit version)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "17crgjfdx55imi2dqnz6xpvsxq07390yfgkz5nd2g77ydkvq9db3"))))
+      (build-system cmake-build-system)
+      (home-page "https://github.com/taocpp/PEGTL")
+      (synopsis "Parsing Expression Grammar Template Library")
+      (description "The Parsing Expression Grammar Template Library (PEGTL) is
+a zero-dependency C++ header-only parser combinator library for creating
+parsers according to a Parsing Expression Grammar (PEG).")
+      (license license:expat)))