diff mbox series

[bug#40980] gnu: xfe: Fix configuration and icons. (v4)

Message ID 20200501124503.4b5cafab.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40980] gnu: xfe: Fix configuration and icons. (v4) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan May 1, 2020, 4:45 p.m. UTC
Hi Danny!

> please use our machine-readable metadata commit log convention instead of
> using free text.
> 
> See our git log.

Sorry about that. I just saw your modified commit message in previous commits.

Please find the revised patch attached with this email.

Regards,
RG.

Comments

Danny Milosavljevic May 1, 2020, 5:21 p.m. UTC | #1
Hi Raghav,

thanks!

Pushed to guix master as commit 7dfc7c5398c16bdf27acf260c71f905d13bb3a9c
with tiny changes.
diff mbox series

Patch

From 7e9c3b41d89e7ba4908cf7894b3222377e162af9 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 1 May 2020 12:31:27 -0400
Subject: [PATCH] gnu: xfe: Fix configuration and icons.

* gnu/packages/disk.scm (xfe):
[arguments]<#:make-flags>[BASH_COMPLETION_DIR]: Remove flag.
[arguments]<#:phases>[patch-xferc-path]: Remove phase.
[arguments]<#:phases>[patch-xfe-paths]: New phase.
---
 gnu/packages/disk.scm | 37 ++++++++++++++++++++++++-------------
 1 file changed, 24 insertions(+), 13 deletions(-)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index b7d3b9d954..e723efebbf 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -917,9 +917,8 @@  since they are better handled by external tools.")
      (origin
        (method url-fetch)
        (uri
-        (string-append "https://sourceforge.net/projects/xfe/files/xfe/"
-                       version
-                       "/xfe-" version ".tar.gz"))
+        (string-append "https://sourceforge.net/projects/xfe/files/xfe/" 
+                       version "/xfe-" version ".tar.gz"))
        (sha256
         (base32 "1fl51k5jm2vrfc2g66agbikzirmp0yb0lqhmsssixfb4mky3hpzs"))))
     (build-system gnu-build-system)
@@ -937,20 +936,32 @@  since they are better handled by external tools.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-xferc-path
+         (add-after 'unpack 'patch-xfe-paths
            (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out     (assoc-ref outputs "out"))
-                    (xferc   (string-append out "/share/xfe/xferc")))
+             (let*
+                 ((out     (assoc-ref outputs "out"))
+                  (share   (string-append out "/share"))
+                  (xferc   (string-append out "/share/xfe/xferc"))
+                  (xfe-theme   (string-append out "/share/xfe/icons/xfe-theme")))
+               ;; Correct path for xfe registry.
+               (substitute* "src/foxhacks.cpp"
+                 (("/etc:/usr/share:/usr/local/share") share))
+               ;; Correct path for xfe configuration.
                (substitute* "src/XFileExplorer.cpp"
-                 (("/usr/share/xfe/xferc") xferc))
-               #t))))
-       #:make-flags
-       (let ((out (assoc-ref %outputs "out")))
-         (list (string-append "BASH_COMPLETION_DIR=" out
-                              "/share/bash-completion/completions")))))
+                 (("/usr/share/xfe/xferc") xferc)
+                 (("/usr/local/share/xfe/xferc") xferc)
+                 (("/opt/local/share/xfe/xferc") xferc))
+               ;; Correct path for xfe icons.
+               (substitute* "src/xfedefs.h"
+                 (((string-append
+                    "~/.config/xfe/icons/xfe-theme:"
+                    "/usr/local/share/xfe/icons/xfe-theme:"
+                    "/usr/share/xfe/icons/xfe-theme"))
+                  xfe-theme))
+               #t))))))
     (synopsis "File Manager for X-Based Graphical Systems")
     (description"XFE (X File Explorer) is a file manager for X.  It is based on
 the popular but discontinued, X Win Commander.  It aims to be the file manager
 of choice for all light thinking Unix addicts!")
     (home-page "http://roland65.free.fr/xfe/")
-    (license license:gpl2+)))
+    (license license:gpl2+)))
\ No newline at end of file
-- 
2.26.2