diff mbox series

[bug#40991] gnu: Add ladspa-bs2b

Message ID 20200501005801.28771-1-jonathan@terracrypt.net
State Accepted
Headers show
Series [bug#40991] gnu: Add ladspa-bs2b | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jonathan Frederickson May 1, 2020, 12:58 a.m. UTC
* gnu/packages/audio.scm (ladspa-bs2b): New variable.
---
 gnu/packages/audio.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Leo Famulari May 1, 2020, 9:38 p.m. UTC | #1
On Thu, Apr 30, 2020 at 08:58:01PM -0400, Jonathan Frederickson wrote:
> * gnu/packages/audio.scm (ladspa-bs2b): New variable.

Thanks! I pushed as ecd56cd1b223733c3ec04043fec245acf4c1cdb8 after
adding a copyright line for you and changing the license field to gpl2+,
since the license header of 'src/plugin.c' includes the "or any later
version" bit.
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e2e276723b..5252704722 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1855,6 +1855,31 @@  for headphone prolonged listening to disable superstereo fatigue without
 essential distortions.")
     (license license:expat)))
 
+(define-public ladspa-bs2b
+  (package
+    (name "ladspa-bs2b")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://sourceforge/bs2b/plugins/LADSPA%20plugin/"
+                    version "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1b4aipbj1ba5k99gbc7gmgy14sywyrjd8rpyqj5l905j0mjv8jg2"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("ladspa" ,ladspa)
+              ("libbs2b" ,libbs2b)))
+    (home-page "https://sourceforge.net/projects/bs2b/")
+    (synopsis "Bauer stereophonic-to-binaural DSP - LADSPA plugin")
+    (description "The Bauer stereophonic-to-binaural DSP (bs2b) library and
+plugins is designed to improve headphone listening of stereo audio records.
+Recommended for headphone prolonged listening to disable superstereo fatigue
+without essential distortions.  This package contains a LADSPA plugin for use
+with applications that support them (e.g. PulseAudio).")
+    (license license:gpl2)))
+
 (define-public liblo
   (package
     (name "liblo")