diff mbox series

[bug#40983] gnu: Add font-api-mj-mincho

Message ID 20200430182709.6b378b1e@tachikoma.lepiller.eu
State Accepted
Headers show
Series [bug#40983] gnu: Add font-api-mj-mincho | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Julien Lepiller April 30, 2020, 4:30 p.m. UTC
Hi,

This patch adds a Japanese font (I recently learned about hentaigana,
and wasn't able to display them, this font solved the issue for me).
The only problem with this package is the license: it sounds like a
free software license to me, but it's not one of the standard ones.

The license is available in Japanese and English in the same file in
the source, and also at the bottom of the home page (you have to click
on "English" to see the English version).

I tried to translate the first sentence of the home page to English,
but my Japanese is limited and I wasn't able to make much sense of the
grammar construction:

IPAmj明朝フォントは、人名の表記等で、細かな字形の差異を特別に使い分ける必要のある業務等での活用を想定したフォントです。

If someone can do better (or maybe some other part of the website gives
a better description?), I'd be glad to use their version!

Comments

Julien Lepiller May 16, 2020, 3:56 p.m. UTC | #1
Le Thu, 30 Apr 2020 18:30:37 +0200,
Julien Lepiller <julien@lepiller.eu> a écrit :

> Hi,
> 
> This patch adds a Japanese font (I recently learned about hentaigana,
> and wasn't able to display them, this font solved the issue for me).
> The only problem with this package is the license: it sounds like a
> free software license to me, but it's not one of the standard ones.
> 
> The license is available in Japanese and English in the same file in
> the source, and also at the bottom of the home page (you have to click
> on "English" to see the English version).
> 
> I tried to translate the first sentence of the home page to English,
> but my Japanese is limited and I wasn't able to make much sense of the
> grammar construction:
> 
> IPAmj明朝フォントは、人名の表記等で、細かな字形の差異を特別に使い分ける必要のある業務等での活用を想定したフォントです。
> 
> If someone can do better (or maybe some other part of the website
> gives a better description?), I'd be glad to use their version!

Pushed as 3c102716d0926602330d3cf616ec9dd0640b7c81.

The license was the IPA license, which is already listed in (guix
licenses).
diff mbox series

Patch

From 4ff2df4a374684570be8a9b0160c640a49f69c39 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Thu, 30 Apr 2020 18:19:11 +0200
Subject: [PATCH] gnu: Add font-api-mj-mincho.

* gnu/packages/fonts.scm (font-api-mj-mincho): New variable.
---
 gnu/packages/fonts.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index dbc0c4f9d6..12e1d7c383 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2020 Amin Bandali <bandali@gnu.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1670,3 +1671,35 @@  always uses Farsi digits, and does not include Latin glyphs from Roboto.
            (license:x11-style           ; ...the Bitstream Vera typeface
             "file://LICENSE" "Bitstream Vera License")
            license:asl2.0))))           ; Latin glyphs from Roboto
+
+(define-public font-ipa-mj-mincho
+  (package
+    (name "font-ipa-mj-mincho")
+    (version "006.01")
+    (source (origin
+              (method url-fetch/zipbomb)
+              (uri (string-append "https://mojikiban.ipa.go.jp/OSCDL/IPAmjMincho"
+                                  "/ipamjm" (string-join (string-split version #\.) "")
+                                  ".zip"))
+              (sha256
+               (base32
+                "0s2vs9p7vd7ajnn6c2icli069sjwi4d45a39fczqpwwn507lwj9m"))))
+    (build-system font-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((doc-dir (string-append (assoc-ref outputs "out")
+                                           "/share/doc/font-ipa-mj-mincho")))
+               (mkdir-p doc-dir)
+               (copy-file "Readme.txt" (string-append doc-dir "/README"))
+               (copy-file "IPA_Font_License_Agreement_v1.0.txt"
+                          (string-append doc-dir "/LICENSE"))
+               #t))))))
+    (home-page "https://mojikiban.ipa.go.jp/1300.html")
+    (synopsis "Japanese font from the Information-technology Promotion Agency")
+    (description "MJM Mincho is a font that aims at, for example, allowing you
+to write people's name, or for formal business situations where it is necessary
+to have a detailed and proper character style.")
+    (license (license:non-copyleft "IPA_Font_License_Agreement_v1.0.txt"))))
-- 
2.26.0