diff mbox series

[bug#40960] gnu: Add audacious. (v4)

Message ID 20200430001035.246d0457.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40960] gnu: Add audacious. (v4) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 30, 2020, 4:10 a.m. UTC

Comments

Danny Milosavljevic May 1, 2020, 9:21 a.m. UTC | #1
Hi Raghav,

thanks for the patch!

When I try to run the program, I get:

LC_ALL=C /gnu/store/n5gw4g2d7yz27329wj6jl0b87c9x07sb-audacious-4.0.3/bin/audacious 
ERROR ../audacious-4.0.3/src/libaudcore/plugin-init.cc:156 [start_required]: No output plugin found.
(Did you forget to install audacious-plugins?)
Aborted

How would it load the plugins?
Raghav Gururajan May 1, 2020, 9:54 a.m. UTC | #2
Hi Danny!

I have closed this bug thread, because it requires more work than I expected. I
will be working on this in future, when I have time. :-)

More work is related to patching the source-code of both audacious and
audacious-plugins packages.

Regards,
RG.
diff mbox series

Patch

From fe1bbc1aa403197cfa19e1fe4ed41b9a079d4c96 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 29 Apr 2020 09:09:26 -0400
Subject: [PATCH] gnu: Add audacious.

* gnu/packages/audio.scm (audacious): New variable.
---
 gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bf16e09f61..52c9d9370e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -111,6 +111,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system qt)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
@@ -123,6 +124,39 @@ 
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26))
 
+(define-public audacious
+  (package
+    (name "audacious")
+    (version "4.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://distfiles.audacious-media-player.org/"
+                       name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "1mkn3wiqmp0mfaxmmcx41mkaz6xi9bl7jkca5g32mwsp332pf0gk"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("glib" ,glib)
+       ("qtbase" ,qtbase)))
+    (synopsis "Lightweight and versatile audio player")
+    (description "Audacious is an audio player software with a focus on low
+resource use, high audio quality, and support for a wide range of audio
+formats.")
+    (home-page "https://audacious-media-player.org/")
+    (license
+     (list
+      license:bsd-2
+      ;; Icons
+      license:cc-by-sa4.0
+      ;; LibGuess
+      license:bsd-3))))
+
 (define-public vo-amrwbenc
   (package
     (name "vo-amrwbenc")
-- 
2.26.2