diff mbox series

[bug#40957,1/?] gnu: rust: Add 1.40

Message ID 20200429094022.22294-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#40957,1/?] gnu: rust: Add 1.40 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka April 29, 2020, 9:40 a.m. UTC
* gnu/packages/rust.scm (rust-1.40): New variable.
---
 gnu/packages/rust.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Debbugs note: I will send patches to add more versions to this bug
number as I get them to work.

Comments

John Soo July 1, 2020, 6:14 a.m. UTC | #1
Hello Jakub and Guix,

I can provide some feedback n this patch set.  I have been using rustc and cargo at 1.44 without issue for two weeks using these patches. I also set 1.44 as the default rust without breakages on x86. 

Hope that helps and thanks for the patches!

- John
Maja Kądziołka July 2, 2020, 11:41 p.m. UTC | #2
On Tue, Jun 30, 2020 at 11:14:09PM -0700, John Soo wrote:
> Hello Jakub and Guix,
> 
> I can provide some feedback n this patch set.  I have been using rustc and cargo at 1.44 without issue for two weeks using these patches. I also set 1.44 as the default rust without breakages on x86. 
> 
> Hope that helps and thanks for the patches!
> 
> - John

Thanks for your feedback! I have pushed the patches, with the difference
that rust-1.44 is 1.44.1 instead.

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 11522b933e..a82bfa5912 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1176,4 +1176,38 @@  move around."
                  (generate-all-checksums "vendor")
                  #t)))))))))
 
+(define-public rust-1.40
+  (let ((base-rust
+         (rust-bootstrapped-package rust-1.39 "1.40.0"
+           "1ba9llwhqm49w7sz3z0gqscj039m53ky9wxzhaj11z6yg1ah15yx")))
+    (package
+      (inherit base-rust)
+      (source
+        (origin
+          (inherit (package-source base-rust))
+          ;; llvm-emscripten is no longer bundled, as that codegen backend
+          ;; got removed.
+          (snippet '(begin
+                      (delete-file-recursively "src/llvm-project")
+                      (delete-file-recursively "vendor/jemalloc-sys/jemalloc")
+                      #t))))
+      (arguments
+       ;; Rust 1.40 does not ship rustc-internal libraries by default
+       ;; (see rustc-dev-split). This means that librustc_driver.so is no
+       ;; longer available in lib/rustlib/$target/lib, which is the directory
+       ;; included in the runpath of librustc_codegen_llvm-llvm.so.
+       ;; This is detected by our validate-runpath phase as an error, but it
+       ;; is harmless as the codegen backend is loaded by librustc_driver.so
+       ;; itself, which must at that point have been already loaded.
+       ;; As such, we skip validating the runpath for Rust 1.40.
+       ;; Rust 1.41 stopped putting the codegen backend in a separate library,
+       ;; which makes this workaround only necessary for this release.
+       (cons* #:validate-runpath? #f
+         (substitute-keyword-arguments (package-arguments base-rust)
+           ((#:phases phases)
+            `(modify-phases ,phases
+               ;; The test got removed in commit 000fe63b6fc57b09828930cacbab20c2ee6e6d15
+               ;; "Remove painful test that is not pulling its weight"
+               (delete 'remove-unsupported-tests)))))))))
+
 (define-public rust rust-1.37)