diff mbox series

[bug#40928,2/2,v2] gnu: Add emacs-kakoune.

Message ID 20200428200633.4a843bf6@airmail.cc
State Accepted
Headers show
Series [bug#40928,1/2,v2] gnu: Add emacs-ryo-modal. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe April 28, 2020, 6:06 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-kakoune): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Nicolas Goaziou April 29, 2020, 2:38 p.m. UTC | #1
Hello,

pinoaffe <pinoaffe@airmail.cc> writes:

> * gnu/packages/emacs-xyz.scm (emacs-kakoune): New variable.

Thank you.

I re-ordered alphabetically the inputs, slightly shortened the synopsis,
and applied the patch.

I suggest to avoid adding new packages at the end of the file, unless
the package name is emacs-zzz. It generates unnecessary conflicts.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2fd16b7388..3f43202551 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22608,3 +22608,33 @@  comments or emails.")
       (description "RYO modal provides a convenient way of defining modal keybindings in Emacs,
 and does not come with any predefined bindings.")
       (license license:expat))))
+
+(define-public emacs-kakoune
+  ;; Package has no release.  Version is extracted from "Version:" keyword in
+  ;; main file.
+  (let ((commit "d73d14e69ea38076af50cc69f846808383ff539d")
+        (revision "0"))
+    (package
+      (name "emacs-kakoune")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/jmorag/kakoune.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0nk6jdy1y5mc3ryd0smiqghrk6iv34d5grc7f7migmshlbq0np92"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-ryo-modal"        ,emacs-ryo-modal)
+         ("emacs-multiple-cursors" ,emacs-multiple-cursors)
+         ("emacs-expand-region"    ,emacs-expand-region)))
+      (home-page "https://github.com/jmorag/kakoune.el")
+      (synopsis "Simple simulation, but not emulation, of Kakoune inside of Emacs")
+      (description "This package provides many, but not all of the editing primitives in the Kakoune editor.
+Unlike Evil mode for vim, this is very shallow emulation, which seeks to do as little
+work as possible, leveraging Emacs native editing commmands and the work of other
+packages wherever possible.")
+      (license license:expat))))