diff mbox series

[bug#40928] Subject: [PATCH 2/2] gnu: Add emacs-kakoune.

Message ID 20200428132656.6e975071@airmail.cc
State Accepted
Headers show
Series [bug#40928] Subject: [PATCH 2/2] gnu: Add emacs-kakoune. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

pinoaffe April 28, 2020, 11:26 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-kakoune): New variable.
---
 gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Nicolas Goaziou April 28, 2020, 3:55 p.m. UTC | #1
Hello,

pinoaffe <pinoaffe@airmail.cc> writes:

> +(define-public emacs-kakoune
> +  (package
> +    (name "emacs-kakoune")
> +    (version "20191017.1502")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append
> +               "https://melpa.org/packages/kakoune-"
> +               version
> +               ".tar"))

See my previous comments about MELPA packaging and versioning.

> +        (sha256
> +          (base32
> +            "1srrrv4fxf99iypch6wyqmiyij4dmq0yrnqnim0y4q0dfvpj63r8"))))

See also my comments about alignment here.

> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +      `(("emacs-ryo-modal"        ,emacs-ryo-modal)
> +        ("emacs-multiple-cursors" ,emacs-multiple-cursors)
> +        ("emacs-expand-region"    ,emacs-expand-region)))
> +    (home-page
> +      "https://github.com/jmorag/kakoune.el")
> +    (synopsis
> +      "A simulation, but not emulation, of kakoune")

Maybe:

  Simple simulation of Kakoune inside of Emacs

> +    (description
> +      "This package provides many, but not all of the editing primitives in the kakoune editor.

kakoune -> Kakoune

> +Unlike evil-mode for vim, this is very shallow emulation, and seeks to do as little

Maybe:

  Unlike, Evil mode for Vim, this is a very shallow emulation, which ...

or even:

  This is a very shallow emulation, which ...

> +work as possible, leveraging Emacs native editing commmands and the work of other
> +packages wherever possible.")

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 37521e92d0..3faa5dd511 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22613,3 +22613,33 @@  ryo-modal does not come with any predefined bindings!
 If you want bindings that only should be active when the region is active,
 please have a look at `selected-minor-mode' (https://github.com/Kungsgeten/selected.el).")
     (license license:expat)))
+
+(define-public emacs-kakoune
+  (package
+    (name "emacs-kakoune")
+    (version "20191017.1502")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://melpa.org/packages/kakoune-"
+               version
+               ".tar"))
+        (sha256
+          (base32
+            "1srrrv4fxf99iypch6wyqmiyij4dmq0yrnqnim0y4q0dfvpj63r8"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+      `(("emacs-ryo-modal"        ,emacs-ryo-modal)
+        ("emacs-multiple-cursors" ,emacs-multiple-cursors)
+        ("emacs-expand-region"    ,emacs-expand-region)))
+    (home-page
+      "https://github.com/jmorag/kakoune.el")
+    (synopsis
+      "A simulation, but not emulation, of kakoune")
+    (description
+      "This package provides many, but not all of the editing primitives in the kakoune editor.
+Unlike evil-mode for vim, this is very shallow emulation, and seeks to do as little
+work as possible, leveraging Emacs native editing commmands and the work of other
+packages wherever possible.")
+    (license license:expat)))