diff mbox series

[bug#40902,v2] gnu: Add edid-decode.

Message ID 20200428095323.4116-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40902,v2] gnu: Add edid-decode. | expand

Commit Message

Brice Waegeneire April 28, 2020, 9:53 a.m. UTC
* gnu/packages/hardware.scm (edid-decode): New variable.
---

Fix identation.  Add phase 'fix-cross-compilation'.

 gnu/packages/hardware.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Mathieu Othacehe April 29, 2020, 9:41 a.m. UTC | #1
Hello Brice,

> +               (when target
> +                 (substitute* "Makefile"
> +                 (("\\$\\(CXX\\)")
> +                  (string-append (assoc-ref native-inputs "gcc") "/bin/g++"))))

Doing that you are still using the native compiler. I changed it to:

--8<---------------cut here---------------start------------->8---
               (when target
                 (substitute* "Makefile"
                   (("\\$\\(CXX\\)")
                    (string-append target "-g++"))))
--8<---------------cut here---------------end--------------->8---

and pushed!

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 189c73ee3c..0128832f28 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -89,6 +89,43 @@  calibrated, and restored when the calibration is applied.")
     (license (list license:bsd-3        ; FindDDCUtil.cmake
                    license:gpl2+))))    ; everything else
 
+(define-public edid-decode
+  (let ((commit "74b64180d67bb009d8d9ea1b6f18ad41aaa16396") ; 2020-04-22
+        (revision "1"))
+    (package
+      (name "edid-decode")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (file-name (git-file-name name version))
+         (uri (git-reference
+               (url "git://linuxtv.org/edid-decode.git")
+               (commit commit)))
+         (sha256
+          (base32 "0nirp5bza08zj5d8bjgcm0p869hdg3qg3mwa7999pjdrzmn7s2ah"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f                     ; No test suite
+         #:make-flags
+         (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+               "bindir=/bin" "mandir=/share/man")
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-cross-compilation
+             (lambda* (#:key native-inputs target #:allow-other-keys)
+               (when target
+                 (substitute* "Makefile"
+                 (("\\$\\(CXX\\)")
+                  (string-append (assoc-ref native-inputs "gcc") "/bin/g++"))))
+               #t))
+           (delete 'configure))))
+      (home-page "https://git.linuxtv.org/edid-decode.git/")
+      (synopsis "Decode @dfn{EDID} data in human-readable format")
+      (description "edid-decode decodes @dfn{EDID} monitor description data in
+human-readable format and check if it conforms to the standards.")
+      (license license:expat))))
+
 ;; Distinct from memtest86, which is obsolete.
 (define-public memtest86+
   (package