diff mbox series

[bug#40908,core-updates,5/5] gnu: make-bootstrap: Do not export %GUILE-STATIC-STRIPPED.

Message ID 20200427182222.28142-5-mbakke@fastmail.com
State Accepted
Headers show
Series Use Guile 3.0 in the initrd | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Marius Bakke April 27, 2020, 6:22 p.m. UTC
* gnu/packages/make-bootstrap.scm (%guile-static-stripped): Remove export.
---
 gnu/packages/make-bootstrap.scm | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Ludovic Courtès April 30, 2020, 10:52 p.m. UTC | #1
Hi,

Marius Bakke <mbakke@fastmail.com> skribis:

> * gnu/packages/make-bootstrap.scm (%guile-static-stripped): Remove export.
> ---
>  gnu/packages/make-bootstrap.scm | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
> index 443e778824..981c7aa24e 100644
> --- a/gnu/packages/make-bootstrap.scm
> +++ b/gnu/packages/make-bootstrap.scm
> @@ -56,9 +56,7 @@
>              %guile-bootstrap-tarball
>              %mescc-tools-bootstrap-tarball
>              %mes-bootstrap-tarball
> -            %bootstrap-tarballs
> -
> -            %guile-static-stripped))

Are you sure it’s unused?

Actually, what about simply adding ‘%guile-3.0-static-stripped’ right in
this file?  I think it would work, right?  And we could also keep
‘make-guile-static’ private.

Apart from this, the patch series LGTM!  Pretty exciting to have a JIT
in the initrd.  ;-)

Thanks,
Ludo’.
Marius Bakke May 1, 2020, 8:16 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> * gnu/packages/make-bootstrap.scm (%guile-static-stripped): Remove export.
>> ---
>>  gnu/packages/make-bootstrap.scm | 4 +---
>>  1 file changed, 1 insertion(+), 3 deletions(-)
>>
>> diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
>> index 443e778824..981c7aa24e 100644
>> --- a/gnu/packages/make-bootstrap.scm
>> +++ b/gnu/packages/make-bootstrap.scm
>> @@ -56,9 +56,7 @@
>>              %guile-bootstrap-tarball
>>              %mescc-tools-bootstrap-tarball
>>              %mes-bootstrap-tarball
>> -            %bootstrap-tarballs
>> -
>> -            %guile-static-stripped))
>
> Are you sure it’s unused?
>
> Actually, what about simply adding ‘%guile-3.0-static-stripped’ right in
> this file?  I think it would work, right?  And we could also keep
> ‘make-guile-static’ private.

Right, that is better.  Done!

> Apart from this, the patch series LGTM!  Pretty exciting to have a JIT
> in the initrd.  ;-)

Heh, my main motivation for these patches was to remove scary warnings
about incompatible bytecode during boot, but we also boot faster as a
side effect!  :-)

Patches pushed!

I think we are pretty close to actually merging this branch now..!
diff mbox series

Patch

diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 443e778824..981c7aa24e 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -56,9 +56,7 @@ 
             %guile-bootstrap-tarball
             %mescc-tools-bootstrap-tarball
             %mes-bootstrap-tarball
-            %bootstrap-tarballs
-
-            %guile-static-stripped))
+            %bootstrap-tarballs))
 
 ;;; Commentary:
 ;;;