diff mbox series

[bug#40862] gnu: Add xarchiver.

Message ID 20200426045129.31f36e15.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40862] gnu: Add xarchiver. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 26, 2020, 8:51 a.m. UTC

Comments

Mathieu Othacehe April 26, 2020, 9:22 a.m. UTC | #1
Hello Raghav,

Thanks for this patch. When running 'guix lint' on this patch, I have
the following warnings:

--8<---------------cut here---------------start------------->8---
/home/mathieu/guix-master/gnu/packages/compression.scm:87:5: xarchiver@0.5.4.14: the source file name should contain the package name
/home/mathieu/guix-master/gnu/packages/compression.scm:87:5: xarchiver@0.5.4.14: the source URI should not be an autogenerated tarball
fetching CVE database for 2020......
fetching CVE database for 2019...
fetching CVE database for 2018...
fetching CVE database for 2017...
/home/mathieu/guix-master/gnu/packages/compression.scm:85:13: xarchiver@0.5.4.14: can be upgraded to 0.5b2
--8<---------------cut here---------------end--------------->8---

>  
> +(define-public xarchiver
> +  (package
> +    (name "xarchiver")
> +    (version "0.5.4.14")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri
> +        (string-append "https://github.com/ib/" name "/archive/"
> +                       version ".tar.gz"))

You should use "git-fetch" method for github repositories (see linter
warning above).

> +       (list
> +        "--disable-plugin")))           ; Not required

Why is it not required?

> +    (synopsis "Graphical Front-end for Archive Operations")

No camel case notation.

> +    (description "Xarchiver is the ultimate solution for handling archives.  It
> +is a desktop-environment independent archiver front end.")

"Ultimate" is maybe exaggerated! Also you could elaborate a bit on the
functionalities of this tool.

Thanks,

Mathieu
diff mbox series

Patch

From 87de8653114475a20235bf91860f622abc8786ec Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 26 Apr 2020 04:47:25 -0400
Subject: [PATCH] gnu: Add xarchiver.

* gnu/packages/compression.scm (xarchiver): New variable.
---
 gnu/packages/compression.scm | 37 ++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e9ef302bcd..a8c27855eb 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -50,6 +50,7 @@ 
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
@@ -63,6 +64,10 @@ 
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages file)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -70,9 +75,41 @@ 
   #:use-module (gnu packages qt)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
+  #:use-module (gnu packages xml)
   #:use-module (ice-9 match)
   #:use-module ((srfi srfi-1) #:select (last)))
 
+(define-public xarchiver
+  (package
+    (name "xarchiver")
+    (version "0.5.4.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://github.com/ib/" name "/archive/"
+                       version ".tar.gz"))
+       (sha256
+        (base32 "0bqajl56z92a26b3is29a38fx777534gbvcn87ajh50aw63fsnrk"))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--disable-plugin")))           ; Not required
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("intltool" ,intltool)
+       ("libxslt" ,libxslt)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("adwaita-icon-theme" ,adwaita-icon-theme) ; Hard-coded theme
+       ("gtk+" ,gtk+)))
+    (synopsis "Graphical Front-end for Archive Operations")
+    (description "Xarchiver is the ultimate solution for handling archives.  It
+is a desktop-environment independent archiver front end.")
+    (home-page "https://github.com/ib/xarchiver")
+    (license license:gpl2+)))
+
 (define-public zlib
   (package
     (name "zlib")
-- 
2.26.2