diff mbox series

[bug#40753] gnu: spacefm: Add dependencies for extra functionality.

Message ID 20200425221143.1a587483.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40753] gnu: spacefm: Add dependencies for extra functionality. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 26, 2020, 2:11 a.m. UTC
Hi Jan!

> Pushed to master with small cosmetic change below.
> 
> Thanks for the patch!

I accidentally sent the wrong patch that missed some things. So sorry. I have
attached a patch with this email to append the previous. Could you please push
it as new commit. Thanks!

Regards,
RG.

Comments

Janneke Nieuwenhuizen April 26, 2020, 2 p.m. UTC | #1
Raghav Gururajan writes:

Hello Raghav,

>> Pushed to master with small cosmetic change below.
>> 
>> Thanks for the patch!
>
> I accidentally sent the wrong patch that missed some things. So sorry. I have
> attached a patch with this email to append the previous. Could you please push
> it as new commit. Thanks!

Don't worry, we all make mistakes.

> From ea9e9909c2929639c1b6574ae61ca9fb0b319177 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Sat, 25 Apr 2020 21:43:25 -0400
> Subject: [PATCH] gnu: spacefm: Fix privilege management and icons.

>>>HERE<<<

> * gnu/packages/lxde.scm (spacefm): Fix privilege management and icons.

Please move this remark:

> This commit contains changes that were accidentally left out in
> commit bf37b49cdd345bcedeb7142f61968d3a6e15e8d8.

beteen subject and "* gnu/packages/lxde", so to >>>HERE<<<

>      (arguments
> -     `(#:configure-flags (list (string-append "--with-bash-path="
> -                                              (assoc-ref %build-inputs "bash")
> -                                              "/bin/bash")
> -                               (string-append "--sysconfdir="
> -                                              (assoc-ref %outputs "out")
> -                                              "/etc"))))
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'patch-spacefm-conf
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (substitute* "etc/spacefm.conf"
> +               (("#terminal_su=/bin/su")
> +                (string-append "terminal_su="
> +                               (string-append (assoc-ref inputs "sudo")
> +                                              "/bin/sudo"))))

Does this work; SU is not SUDO?  Also, I don't see how <sudo>/bin/sudo
would work.  When I run this

    $(guix build sudo)/bin/sudo 

I get

    sudo: /gnu/store/l320ig872ny66d1yi6v7n4zb93iz50dx-sudo-1.8.31p1/bin/sudo must be owned by uid 0 and have the setuid bit set

Am I missing something?

> +             (substitute* "etc/spacefm.conf"
> +               (("#graphical_su=/usr/bin/gksu")
> +                (string-append "graphical_su="
> +                               (string-append (assoc-ref inputs "ktsuss")
> +                                              "/bin/ktsuss"))))
> +             #t)))

Changing the default configurations does not seem to work for me.  When
I select

    /File/Root Window

there is a pop-up that says: Please configure a valid Terminal SU
command.  Does it work for You?

> +       #:configure-flags (list 
                                 ^
Trailing space.

Greetings,
janneke
diff mbox series

Patch

From ea9e9909c2929639c1b6574ae61ca9fb0b319177 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sat, 25 Apr 2020 21:43:25 -0400
Subject: [PATCH] gnu: spacefm: Fix privilege management and icons.

* gnu/packages/lxde.scm (spacefm): Fix privilege management and icons.

This commit contains changes that were accidentally left out in
commit bf37b49cdd345bcedeb7142f61968d3a6e15e8d8.
---
 gnu/packages/lxde.scm | 37 ++++++++++++++++++++++++++++++-------
 1 file changed, 30 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9de96a21cb..3fd2eaff69 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,6 +27,7 @@ 
 
 (define-module (gnu packages lxde)
   #:use-module (gnu packages)
+  #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages disk)
@@ -276,7 +277,8 @@  with freedesktop.org standard.")
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("bash" ,bash)
+     `(("adwaita-icon-theme" ,adwaita-icon-theme) ; Hard-coded theme
+       ("bash" ,bash)
        ("cairo" ,cairo)
        ("curlftpfs" ,curlftpfs)
        ("dbus" ,dbus)
@@ -288,21 +290,42 @@  with freedesktop.org standard.")
        ("gtk+" ,gtk+)
        ("ifuse" ,ifuse)
        ("jmtpfs" ,jmtpfs)
+       ("ktsuss" ,ktsuss)
        ("libx11" ,libx11)
        ("lsof" ,lsof)
        ("pango" ,pango)
        ("shared-mime-info" ,shared-mime-info)
        ("startup-notification" ,startup-notification)
+       ("sudo" ,sudo)
        ("udevil" ,udevil)
        ("util-linux" ,util-linux)
        ("wget" ,wget)))
     (arguments
-     `(#:configure-flags (list (string-append "--with-bash-path="
-                                              (assoc-ref %build-inputs "bash")
-                                              "/bin/bash")
-                               (string-append "--sysconfdir="
-                                              (assoc-ref %outputs "out")
-                                              "/etc"))))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-spacefm-conf
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "etc/spacefm.conf"
+               (("#terminal_su=/bin/su")
+                (string-append "terminal_su="
+                               (string-append (assoc-ref inputs "sudo")
+                                              "/bin/sudo"))))
+             (substitute* "etc/spacefm.conf"
+               (("#graphical_su=/usr/bin/gksu")
+                (string-append "graphical_su="
+                               (string-append (assoc-ref inputs "ktsuss")
+                                              "/bin/ktsuss"))))
+             #t)))
+       #:configure-flags (list 
+                          (string-append "--with-preferable-sudo="
+                                         (assoc-ref %build-inputs "ktsuss")
+                                         "/bin/ktsuss")
+                          (string-append "--with-bash-path="
+                                         (assoc-ref %build-inputs "bash")
+                                         "/bin/bash")
+                          (string-append "--sysconfdir="
+                                         (assoc-ref %outputs "out")
+                                         "/etc"))))
     (home-page "https://ignorantguru.github.io/spacefm/")
     (synopsis "Multi-panel tabbed file manager")
     (description "SpaceFM is a graphical, multi-panel, tabbed file manager
-- 
2.26.1