diff mbox series

[bug#40756] gnu: Add ktsuss. (v3)

Message ID 20200424152302.608f23c2.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40756] gnu: Add ktsuss. (v3) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 24, 2020, 7:23 p.m. UTC
On Fri, 24 Apr 2020 15:21:31 -0400
Raghav Gururajan <raghavgururajan@disroot.org> wrote:

> Hi Nicolas!
> 
> > > Subject: [PATCH 4/4] gnu: Add ktsuss.    
> > 
> > Thank you! 
> > 
> > It looks mostly good. I have some comments, tho.
> >   
> > > +       (modify-phases %standard-phases
> > > +         (add-after 'unpack 'patch    
> > 
> > Could you provide a more insightful name for the new phase? :)
> >   
> > > +           (lambda _
> > > +             (substitute* "configure.ac"
> > > +               (("sudopath=`which sudo 2>/dev/null`")
> > > +                (string-append "sudopath="
> > > +                               (string-append (assoc-ref %build-inputs
> > > "sudo")
> > > +                                              "/bin/sudo"))))    
> > 
> > Please use (lambda* (#:key inputs #:allow-other-keys) ...) and `inputs'
> > instead of the magical %build-inputs.
> >   
> > > +    (synopsis "Graphical front-end for Su")    
> > 
> > I would write:
> > 
> >   Graphical front end for @command{su}
> >   
> > > +    (description "Ktsuss stands for 'keep the su simple, stupid', and as
> > > the +name says, is a graphical version (frontend) of su written in C and
> > > GTK+ 2.  The +idea of the project is to remain simple and bug free.")    
> > 
> > What about :
> > 
> >     (description
> >      "Ktsuss stands for ``Keep the @command{su} simple, stupid''.
> > It is a graphical version of @command{su} written in C and GTK+ 2,
> > with simplicity in mind.")
> >   
> > > +    (license
> > > +     (list
> > > +      (license:non-copyleft "file://COPYING")
> > > +      (license:non-copyleft "file://LICENSE")))))    
> > 
> > It looks like the license is `bsd-3'. Do you have any reason to think
> > otherwise ?
> > 
> > Could you send an updated patch?  
> 
> Thank you for the feedback. Please find the updated patch attached with this
> email.
> 
> Regards,
> RG.

Comments

Nicolas Goaziou April 24, 2020, 8:12 p.m. UTC | #1
Hello,

Raghav Gururajan <raghavgururajan@disroot.org> writes:

> Subject: [PATCH] gnu: Add ktsuss.
>
> * gnu/packages/admin.scm (ktsuss): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 4a54ba65fbb201fc346af8c4580ce2991ea8e68d Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 24 Apr 2020 15:18:59 -0400
Subject: [PATCH] gnu: Add ktsuss.

* gnu/packages/admin.scm (ktsuss): New variable.
---
 gnu/packages/admin.scm | 49 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 619a419170..80c2e05336 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -52,6 +52,7 @@ 
 (define-module (gnu packages admin)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system emacs)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
@@ -64,6 +65,7 @@ 
   #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages autogen)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
@@ -128,6 +130,53 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public ktsuss
+  (package
+    (name "ktsuss")
+    (version "2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/nomius/ktsuss.git")
+         (commit version)))
+       (sha256
+        (base32 "0q9931f9hp47v1n8scli4bdg2rkjpf5jf8v7jj2gdn83aia1r2hz"))
+       (file-name (git-file-name name version))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--enable-sudo=yes")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-sudo-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "configure.ac"
+               (("sudopath=`which sudo 2>/dev/null`")
+                (string-append "sudopath="
+                               (string-append (assoc-ref inputs "sudo")
+                                              "/bin/sudo"))))
+             #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("autogen" ,autogen)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+-2)
+       ("sudo" ,sudo)))
+    (synopsis "Graphical front end for @command{su}")
+    (description "Ktsuss stands for 'keep the @command{su} simple, stupid',
+and as the name says, is a graphical version (frontend) of @command{su}
+written in C and GTK+ 2.  The idea of the project is to remain simple and
+bug free.")
+    (home-page "https://github.com/nomius/ktsuss")
+    (license license:bsd-3)))
+
 (define-public aide
   (package
     (name "aide")
-- 
2.26.1