diff mbox series

[bug#40683,v2] gnu: Add wireguard-linux-module.

Message ID 20200423123457.23843-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40683,v2] gnu: Add wireguard-linux-module. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire April 23, 2020, 12:34 p.m. UTC
* gnu/packages/vpn.scm (wireguard-linux-module): New variable.
---

Rename wireguard-module to wireguard-linux-module and remove documentation from the
description.

 gnu/packages/vpn.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Leo Famulari April 23, 2020, 5:03 p.m. UTC | #1
On Thu, Apr 23, 2020 at 02:34:57PM +0200, Brice Waegeneire wrote:
> * gnu/packages/vpn.scm (wireguard-linux-module): New variable.

Can this be part of the wireguard-linux-compat package? I think it's
confusing to have two packages providing WireGuard for old kernels.
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 739522959c..be600524f5 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,6 +35,7 @@ 
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system linux-module)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
@@ -496,6 +498,24 @@  The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
 kernel versions 3.10 through 5.5.  WireGuard was added to Linux 5.6.")
     (license license:gpl2)))
 
+(define-public wireguard-linux-module
+  (package
+    (inherit wireguard-linux-compat)
+    (name "wireguard-linux-module")
+    (build-system linux-module-build-system)
+    (arguments
+     `(#:tests? #f                      ; No test suite
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'change-directory
+           (lambda _
+             (chdir "./src")
+             #t)))))
+    (synopsis "WireGuard loadable kernel module for Linux 3.10 through 5.5")
+    (description "This is a loadable Linux kernel module for WireGuard
+supporting kernel versions 3.10 through 5.5.  WireGuard was added to Linux
+5.6.")))
+
 (define-public wireguard-tools
   (package
     (name "wireguard-tools")