diff mbox series

[bug#40786] * gnu: Add emacs-twittering-mode.

Message ID 20200423012524.13469-1-masaya@tojo.tokyo
State Accepted
Headers show
Series [bug#40786] * gnu: Add emacs-twittering-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Masaya Tojo April 23, 2020, 1:25 a.m. UTC
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou April 28, 2020, 3:23 p.m. UTC | #1
Hello,

Masaya Tojo <masaya@tojo.tokyo> writes:

> +(define-public emacs-twittering-mode

Thank you! Could you also provide a commit message for this? For new
variables, it is usually:

  gnu: Add emacs-twittering-mode

  * gnu/packages/emacs-xyz.scm (emacs-twittering-mode): New variable.

If no one objects to this, I'll commit when you send me an updated patch.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32b1868813..8c12332b69 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22534,3 +22534,23 @@  ASCII UML sequence diagrams in Emacs, which can be embedded in source code,
 comments or emails.")
       (license license:gpl3+))))
 
+(define-public emacs-twittering-mode
+  (package
+    (name "emacs-twittering-mode")
+    (version "3.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/twmode"
+                           "/twittering-mode-" version
+                           "/twittering-mode-" version ".tar.xz"))
+       (sha256
+        (base32 "02imis1gxz90lah0b5n37j2hlsaw5igss11d85vpsm5d1bgw8j28"))))
+    (build-system emacs-build-system)
+    (home-page "http://twmode.sourceforge.net")
+    (synopsis "Emacs major mode for Twitter")
+    (description
+     "Twittering-mode is an Emacs major mode for Twitter.
+You can check timelines, tweet, mark posts as favorites and so on
+with Emacs.")
+    (license license:gpl2+)))