diff mbox series

[bug#40753] gnu: spacefm: Add missing dependencies. (v3)

Message ID 20200422162239.0a98a5c3.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40753] gnu: spacefm: Add missing dependencies. (v3) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 22, 2020, 8:22 p.m. UTC
Hi Jan!

> Right.  So we'll have to wait for those then, right?

Pardon me, I should have communicated better. I was asking to push including
the blockers. Would you be able to please? If not, that's okay.

> Okay, it would be nice to say something about that in the commit
> message.  What about
> 
>     gnu: spacefm: Add dependencies for extra functionality.
> 
>     Adding these inputs provides adds icons, privilege-management and
>     disk-management.

Thanks. Please find the revised patch attached with this email.

> Other than that, LGTM (assuming that it builds).  I'm not really able
> to test it, I assume it works for you as you expected?

Yes, all works good. :-)

> No worries!  I did not have much time this morning and from your ping
> assumed a trivial task.  Teaches me not to assume things.

No, you did not do anything wrong. I should have communicated better.

> I would suggest that when you get an OK on the last dependency for this
> one, you mention this patch again.

Sure. But let me know if you would be able to process the blockers as well.

> Please consider sending patches that depend on eachother in one bug
> report if that makes sense.

Sorry, I did not plan on fixing spacefm. I came across the issues with spacefm
after sending those other patches.

Regards,
RG.
diff mbox series

Patch

From b4f659e7c43eebb4f27f5c1d208a0326d7f2e6a6 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 22 Apr 2020 16:15:34 -0400
Subject: [PATCH 4/4] gnu: spacefm: Add dependencies for extra functionality.

* gnu/packages/lxde.scm (spacefm): Add dependencies for extra functionality.

Adding these inputs and making required changes to build-system+arguments;
provides icons, privilege-management and disk-management.
---
 gnu/packages/lxde.scm | 50 +++++++++++++++++++++++++++++++------------
 1 file changed, 36 insertions(+), 14 deletions(-)

diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..eeb9feb745 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -29,13 +29,16 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages file-systems)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image-viewers)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lsof)
   #:use-module (gnu packages openbox)
@@ -43,9 +46,12 @@ 
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages text-editors)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages wget)
   #:use-module (gnu packages wm)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
@@ -249,8 +255,8 @@  with freedesktop.org standard.")
                     "https://github.com/IgnorantGuru/spacefm/archive/"
                     version ".tar.gz"))
               (sha256
-                (base32
-                 "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+               (base32
+                "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -262,18 +268,34 @@  with freedesktop.org standard.")
                                     "#include <sys/sysmacros.h>\n")))
                   #t))
               (file-name (string-append name "-" version ".tar.gz"))))
-    (build-system gnu-build-system)
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("desktop-file-utils" ,desktop-file-utils)
-                     ("intltool" ,intltool)))
-    (inputs `(("bash" ,bash)
-              ("gtk+" ,gtk+)
-              ("eudev" ,eudev)
-              ("shared-mime-info" ,shared-mime-info)
-              ("ffmpegthumbnailer" ,ffmpegthumbnailer)
-              ("jmtpfs" ,jmtpfs)
-              ("lsof" ,lsof)
-              ("udisks" ,udisks)))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bash" ,bash)
+       ("cairo" ,cairo)
+       ("curlftpfs" ,curlftpfs)
+       ("dbus" ,dbus)
+       ("eject" ,eject)
+       ("eudev" ,eudev)
+       ("fakeroot" ,fakeroot)
+       ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+       ("fuseiso" ,fuseiso)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("ifuse" ,ifuse)
+       ("jmtpfs" ,jmtpfs)
+       ("libx11" ,libx11)
+       ("lsof" ,lsof)
+       ("pango" ,pango)
+       ("shared-mime-info" ,shared-mime-info)
+       ("startup-notification" ,startup-notification)
+       ("udevil" ,udevil)
+       ("wget" ,wget)))
     (arguments
      `(#:configure-flags (list (string-append "--with-bash-path="
                                               (assoc-ref %build-inputs "bash")
-- 
2.26.1