diff mbox series

[bug#40753] gnu: spacefm: Add and configure missing dependencies. (v2)

Message ID 20200421201550.5133dd86.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40753] gnu: spacefm: Add and configure missing dependencies. (v2) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 22, 2020, 12:15 a.m. UTC
BLOCKERS: #40630, #40752 and #40756.
diff mbox series

Patch

From 43cd81fdbe7522cd5ed7f638e49438bfd1a2ccff Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 21 Apr 2020 20:10:50 -0400
Subject: [PATCH 4/4] gnu: spacefm: Add and configure missing dependencies.

* gnu/packages/lxde.scm (spacefm): Add and configure missing dependencies.
---
 gnu/packages/lxde.scm | 81 ++++++++++++++++++++++++++++++++-----------
 1 file changed, 61 insertions(+), 20 deletions(-)

diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..e6fc5b14c8 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -27,15 +27,19 @@ 
 
 (define-module (gnu packages lxde)
   #:use-module (gnu packages)
+  #:use-module (gnu packages admin)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages file-systems)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image-viewers)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lsof)
   #:use-module (gnu packages openbox)
@@ -43,9 +47,12 @@ 
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages text-editors)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages wget)
   #:use-module (gnu packages wm)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
@@ -249,8 +256,8 @@  with freedesktop.org standard.")
                     "https://github.com/IgnorantGuru/spacefm/archive/"
                     version ".tar.gz"))
               (sha256
-                (base32
-                 "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+               (base32
+                "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -262,25 +269,59 @@  with freedesktop.org standard.")
                                     "#include <sys/sysmacros.h>\n")))
                   #t))
               (file-name (string-append name "-" version ".tar.gz"))))
-    (build-system gnu-build-system)
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("desktop-file-utils" ,desktop-file-utils)
-                     ("intltool" ,intltool)))
-    (inputs `(("bash" ,bash)
-              ("gtk+" ,gtk+)
-              ("eudev" ,eudev)
-              ("shared-mime-info" ,shared-mime-info)
-              ("ffmpegthumbnailer" ,ffmpegthumbnailer)
-              ("jmtpfs" ,jmtpfs)
-              ("lsof" ,lsof)
-              ("udisks" ,udisks)))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bash" ,bash)
+       ("cairo" ,cairo)
+       ("curlftpfs" ,curlftpfs)
+       ("dbus" ,dbus)
+       ("eject" ,eject)
+       ("eudev" ,eudev)
+       ("fakeroot" ,fakeroot)
+       ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+       ("fuseiso" ,fuseiso)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("ifuse" ,ifuse)
+       ("jmtpfs" ,jmtpfs)
+       ("ktsuss" ,ktsuss)
+       ("libx11" ,libx11)
+       ("lsof" ,lsof)
+       ("pango" ,pango)
+       ("shared-mime-info" ,shared-mime-info)
+       ("startup-notification" ,startup-notification)
+       ("sudo" ,sudo)
+       ("udevil" ,udevil)
+       ("wget" ,wget)))
     (arguments
-     `(#:configure-flags (list (string-append "--with-bash-path="
-                                              (assoc-ref %build-inputs "bash")
-                                              "/bin/bash")
-                               (string-append "--sysconfdir="
-                                              (assoc-ref %outputs "out")
-                                              "/etc"))))
+     `(#:configure-flags (list
+                          (string-append "--with-bash-path="
+                                         (assoc-ref %build-inputs "bash")
+                                         "/bin/bash")
+                          (string-append "--sysconfdir="
+                                         (assoc-ref %outputs "out")
+                                         "/etc"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "etc/spacefm.conf"
+               (("#terminal_su=/bin/su")
+                (string-append "terminal_su="
+                               (string-append (assoc-ref %build-inputs "sudo")
+                                              "/bin/sudo"))))
+             (substitute* "etc/spacefm.conf"
+               (("#graphical_su=/usr/bin/gksu")
+                (string-append "graphical_su="
+                               (string-append (assoc-ref %build-inputs "ktsuss")
+                                              "/bin/ktsuss"))))
+             #t)))))
     (home-page "https://ignorantguru.github.io/spacefm/")
     (synopsis "Multi-panel tabbed file manager")
     (description "SpaceFM is a graphical, multi-panel, tabbed file manager
-- 
2.26.1