diff mbox series

[bug#40756] gnu: Add ktsuss.

Message ID 20200421192622.7d6412e0.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40756] gnu: Add ktsuss. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 21, 2020, 11:26 p.m. UTC

Comments

Nicolas Goaziou April 23, 2020, 8:17 a.m. UTC | #1
Hello,

Raghav Gururajan <raghavgururajan@disroot.org> writes:

> Subject: [PATCH 4/4] gnu: Add ktsuss.

Thank you! 

It looks mostly good. I have some comments, tho.

> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'patch

Could you provide a more insightful name for the new phase? :)

> +           (lambda _
> +             (substitute* "configure.ac"
> +               (("sudopath=`which sudo 2>/dev/null`")
> +                (string-append "sudopath="
> +                               (string-append (assoc-ref %build-inputs "sudo")
> +                                              "/bin/sudo"))))

Please use (lambda* (#:key inputs #:allow-other-keys) ...) and `inputs'
instead of the magical %build-inputs.

> +    (synopsis "Graphical front-end for Su")

I would write:

  Graphical front end for @command{su}

> +    (description "Ktsuss stands for 'keep the su simple, stupid', and as the
> +name says, is a graphical version (frontend) of su written in C and GTK+ 2.  The
> +idea of the project is to remain simple and bug free.")

What about :

    (description
     "Ktsuss stands for ``Keep the @command{su} simple, stupid''.
It is a graphical version of @command{su} written in C and GTK+ 2,
with simplicity in mind.")

> +    (license
> +     (list
> +      (license:non-copyleft "file://COPYING")
> +      (license:non-copyleft "file://LICENSE")))))

It looks like the license is `bsd-3'. Do you have any reason to think
otherwise ?

Could you send an updated patch?

Regards,
Raghav Gururajan April 24, 2020, 7:21 p.m. UTC | #2
Hi Nicolas!

> > Subject: [PATCH 4/4] gnu: Add ktsuss.  
> 
> Thank you! 
> 
> It looks mostly good. I have some comments, tho.
> 
> > +       (modify-phases %standard-phases
> > +         (add-after 'unpack 'patch  
> 
> Could you provide a more insightful name for the new phase? :)
> 
> > +           (lambda _
> > +             (substitute* "configure.ac"
> > +               (("sudopath=`which sudo 2>/dev/null`")
> > +                (string-append "sudopath="
> > +                               (string-append (assoc-ref %build-inputs
> > "sudo")
> > +                                              "/bin/sudo"))))  
> 
> Please use (lambda* (#:key inputs #:allow-other-keys) ...) and `inputs'
> instead of the magical %build-inputs.
> 
> > +    (synopsis "Graphical front-end for Su")  
> 
> I would write:
> 
>   Graphical front end for @command{su}
> 
> > +    (description "Ktsuss stands for 'keep the su simple, stupid', and as
> > the +name says, is a graphical version (frontend) of su written in C and
> > GTK+ 2.  The +idea of the project is to remain simple and bug free.")  
> 
> What about :
> 
>     (description
>      "Ktsuss stands for ``Keep the @command{su} simple, stupid''.
> It is a graphical version of @command{su} written in C and GTK+ 2,
> with simplicity in mind.")
> 
> > +    (license
> > +     (list
> > +      (license:non-copyleft "file://COPYING")
> > +      (license:non-copyleft "file://LICENSE")))))  
> 
> It looks like the license is `bsd-3'. Do you have any reason to think
> otherwise ?
> 
> Could you send an updated patch?

Thank you for the feedback. Please find the updated patch attached with this
email.

Regards,
RG.
diff mbox series

Patch

From 9fff550b6719e9d52ba4e500360240d7adc76538 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 21 Apr 2020 19:17:35 -0400
Subject: [PATCH 4/4] gnu: Add ktsuss.

* gnu/packages/admin.scm (ktsuss): New variable.
---
 gnu/packages/admin.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index bf5aa9d890..6744624067 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -52,6 +52,7 @@ 
 (define-module (gnu packages admin)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system emacs)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
@@ -64,6 +65,7 @@ 
   #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages autogen)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
@@ -128,6 +130,55 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public ktsuss
+  (package
+    (name "ktsuss")
+    (version "2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/nomius/ktsuss.git")
+         (commit version)))
+       (sha256
+        (base32 "0q9931f9hp47v1n8scli4bdg2rkjpf5jf8v7jj2gdn83aia1r2hz"))
+       (file-name (git-file-name name version))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--enable-sudo=yes")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "configure.ac"
+               (("sudopath=`which sudo 2>/dev/null`")
+                (string-append "sudopath="
+                               (string-append (assoc-ref %build-inputs "sudo")
+                                              "/bin/sudo"))))
+             #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("autogen" ,autogen)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+-2)
+       ("sudo" ,sudo)))
+    (synopsis "Graphical front-end for Su")
+    (description "Ktsuss stands for 'keep the su simple, stupid', and as the
+name says, is a graphical version (frontend) of su written in C and GTK+ 2.  The
+idea of the project is to remain simple and bug free.")
+    (home-page "https://github.com/nomius/ktsuss")
+    (license
+     (list
+      (license:non-copyleft "file://COPYING")
+      (license:non-copyleft "file://LICENSE")))))
+
 (define-public aide
   (package
     (name "aide")
-- 
2.26.1