diff mbox series

[bug#40753] gnu: spacefm: Add missing dependencies.

Message ID 20200421172812.6227b2eb.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40753] gnu: spacefm: Add missing dependencies. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 21, 2020, 9:28 p.m. UTC
BLOCKERS: #40630 and #40752.

Comments

Janneke Nieuwenhuizen April 22, 2020, 6:46 a.m. UTC | #1
Raghav Gururajan writes:

Hello!

> BLOCKERS: #40630 and #40752.

...what does this mean?

>>From fac881e2820c08e09c8f3e42699ba25b8b9f4004 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Tue, 21 Apr 2020 17:23:21 -0400
> Subject: [PATCH 3/3] gnu: spacefm: Add missing dependencies.

> * gnu/packages/lxde.scm (spacefm): Add missing dependencies.

It builds OK without this patch; it does not seem that any dependencies
are missing.  Could it be that these dependencies change or amend its
behaviour?

After applying this patch, spacefm does not build for me, I get

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix build spacefm
ice-9/eval.scm:223:20: In procedure proc:
error: eject: unbound variable
hint: Did you forget a `use-modules' form?
--8<---------------cut here---------------end--------------->8---

I am feeling a bit uncomfortable about the fact that you pinged me to
"push" this patch, it seems it needs a bit more attention than that.

Greetings,
janneke
Raghav Gururajan April 22, 2020, 4:28 p.m. UTC | #2
Hi Jan!

> > BLOCKERS: #40630 and #40752.  
> 
> ...what does this mean?

They are dependencies of this patch, that needs to be pushed before this patch.

> It builds OK without this patch; it does not seem that any dependencies
> are missing.  Could it be that these dependencies change or amend its
> behaviour?

It is to change and amend the behaviour. It adds missing features and fixes
icons+privilege-management+disk-management.

> After applying this patch, spacefm does not build for me, I get
> 
> --8<---------------cut here---------------start------------->8---
> $ ./pre-inst-env guix build spacefm
> ice-9/eval.scm:223:20: In procedure proc:
> error: eject: unbound variable
> hint: Did you forget a `use-modules' form?
> --8<---------------cut here---------------end--------------->8---

That's correct. Eject is provided by one of the blockers.

> I am feeling a bit uncomfortable about the fact that you pinged me to
> "push" this patch, it seems it needs a bit more attention than that.

I apologize. I spent whole day to create these patches and throughly testing
them. If I missed anything, please understand it would not have been
intentional. Also, there is a v2 patch in #40753 thread that has 3 blockers.

Thank you for considering my request.

Regards,
RG.
Janneke Nieuwenhuizen April 22, 2020, 5:59 p.m. UTC | #3
Raghav Gururajan writes:

Hello Raghav,

>> > BLOCKERS: #40630 and #40752.  
>> 
>> ...what does this mean?
>
> They are dependencies of this patch, that needs to be pushed before
> this patch.

Right.  So we'll have to wait for those then, right?

>> It builds OK without this patch; it does not seem that any dependencies
>> are missing.  Could it be that these dependencies change or amend its
>> behaviour?
>
> It is to change and amend the behaviour. It adds missing features and fixes
> icons+privilege-management+disk-management.

Okay, it would be nice to say something about that in the commit
message.  What about

    gnu: spacefm: Add dependencies for extra functionality.

    Adding these inputs provides adds icons, privilege-management and
    disk-management.

Other than that, LGTM (assuming that it builds).  I'm not really able
to test it, I assume it works for you as you expected?

>> I am feeling a bit uncomfortable about the fact that you pinged me to
>> "push" this patch, it seems it needs a bit more attention than that.
>
> I apologize. I spent whole day to create these patches and throughly testing
> them. If I missed anything, please understand it would not have been
> intentional. Also, there is a v2 patch in #40753 thread that has 3 blockers.
>
> Thank you for considering my request.

No worries!  I did not have much time this morning and from your ping
assumed a trivial task.  Teaches me not to assume things.

I would suggest that when you get an OK on the last dependency for this
one, you mention this patch again.

Please consider sending patches that depend on eachother in one bug
report if that makes sense.

Greetings,
janneke
diff mbox series

Patch

From fac881e2820c08e09c8f3e42699ba25b8b9f4004 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 21 Apr 2020 17:23:21 -0400
Subject: [PATCH 3/3] gnu: spacefm: Add missing dependencies.

* gnu/packages/lxde.scm (spacefm): Add missing dependencies.
---
 gnu/packages/lxde.scm | 50 +++++++++++++++++++++++++++++++------------
 1 file changed, 36 insertions(+), 14 deletions(-)

diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index f5dc027e03..eeb9feb745 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -29,13 +29,16 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages disk)
   #:use-module (gnu packages docbook)
+  #:use-module (gnu packages file-systems)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image-viewers)
+  #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages lsof)
   #:use-module (gnu packages openbox)
@@ -43,9 +46,12 @@ 
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages text-editors)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages wget)
   #:use-module (gnu packages wm)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (guix download)
@@ -249,8 +255,8 @@  with freedesktop.org standard.")
                     "https://github.com/IgnorantGuru/spacefm/archive/"
                     version ".tar.gz"))
               (sha256
-                (base32
-                 "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+               (base32
+                "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -262,18 +268,34 @@  with freedesktop.org standard.")
                                     "#include <sys/sysmacros.h>\n")))
                   #t))
               (file-name (string-append name "-" version ".tar.gz"))))
-    (build-system gnu-build-system)
-    (native-inputs `(("pkg-config" ,pkg-config)
-                     ("desktop-file-utils" ,desktop-file-utils)
-                     ("intltool" ,intltool)))
-    (inputs `(("bash" ,bash)
-              ("gtk+" ,gtk+)
-              ("eudev" ,eudev)
-              ("shared-mime-info" ,shared-mime-info)
-              ("ffmpegthumbnailer" ,ffmpegthumbnailer)
-              ("jmtpfs" ,jmtpfs)
-              ("lsof" ,lsof)
-              ("udisks" ,udisks)))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bash" ,bash)
+       ("cairo" ,cairo)
+       ("curlftpfs" ,curlftpfs)
+       ("dbus" ,dbus)
+       ("eject" ,eject)
+       ("eudev" ,eudev)
+       ("fakeroot" ,fakeroot)
+       ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+       ("fuseiso" ,fuseiso)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("ifuse" ,ifuse)
+       ("jmtpfs" ,jmtpfs)
+       ("libx11" ,libx11)
+       ("lsof" ,lsof)
+       ("pango" ,pango)
+       ("shared-mime-info" ,shared-mime-info)
+       ("startup-notification" ,startup-notification)
+       ("udevil" ,udevil)
+       ("wget" ,wget)))
     (arguments
      `(#:configure-flags (list (string-append "--with-bash-path="
                                               (assoc-ref %build-inputs "bash")
-- 
2.26.1