diff mbox series

[bug#40673,v2] gnu: add wf-recorder

Message ID 20200416205527.22890-1-amk@amk.ie
State Accepted
Headers show
Series [bug#40673,v2] gnu: add wf-recorder | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alex McGrath April 16, 2020, 8:55 p.m. UTC
A v2 patch as i forgot to add a copyright notice, and forgot to change the homepage

---
 gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Mathieu Othacehe April 27, 2020, 4:24 p.m. UTC | #1
Hello Alex,

Sorry for the delay. I changed the license, edited a bit the
description, added a Change-log compatible commit message and pushed!

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 62cc423c09..72746ea2fb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Alex McGrath <amk@amk.ie>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3920,3 +3921,33 @@  work-in-progress, aiming to support video-on-demand and live streaming
 applications.  It only supports Intel-compatible CPUs (x86).")
     (home-page "https://github.com/OpenVisualCloud/SVT-AV1")
     (license license:bsd-2)))
+
+(define-public wf-recorder
+  (package
+    (name "wf-recorder")
+    (version "0.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ammen99/wf-recorder.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1cw6kpcbl33wh95pvy32xrsrm6kkk1awccr3phyh885xjs3b3iim"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("ffmpeg" ,ffmpeg)
+       ("pulseaudio" ,pulseaudio)
+       ("wayland" ,wayland)
+       ("wayland-protocols" ,wayland-protocols)
+       ("libx264" ,libx264)))
+    (home-page "https://github.com/ammen99/wf-recorder.git")
+    (synopsis "Screen recorder for wlroots-based compositors")
+    (description
+     "wf-recorder is a utility program for screen recording of wlroots-based
+compositors (more specifically, those that support wlr-screencopy-v1 and
+xdg-output)")
+    (license license:mit)))