diff mbox series

[bug#40660] gnu: Add linphoneqt. (v2)

Message ID 20200416102749.4607d34c.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40660] gnu: Add linphoneqt. (v2) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 16, 2020, 2:27 p.m. UTC

Comments

Raghav Gururajan April 16, 2020, 4:36 p.m. UTC | #1
A
Maxim Cournoyer April 18, 2020, 5:32 a.m. UTC | #2
Hello Raghav!

Raghav Gururajan <raghavgururajan@disroot.org> writes:

>>From 6e018522c30cb2a9732ccde98df32118c7699d7f Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Thu, 16 Apr 2020 10:26:11 -0400
> Subject: [PATCH] gnu: Add linphoneqt.
>
> * gnu/packages/linphone.scm (linphoneqt): New variable.
> ---
>  .../patches/linphoneqt-tabbutton.patch        | 96 +++++++++++++++++++
>  1 file changed, 96 insertions(+)
>  create mode 100644 gnu/packages/patches/linphoneqt-tabbutton.patch

This with the previous patch resolved the crashes, but I could only make
linphoneqt run on core-updates, not on the latest master.  On master, I
get the error:

linphone
MESA-LOADER: failed to open nouveau (search paths /gnu/store/qlzbx7a36brydrxbss71smwlrk539y9i-mesa-19.3.4/lib/dri)
libGL error: failed to load driver: nouveau
MESA-LOADER: failed to open swrast (search paths /gnu/store/qlzbx7a36brydrxbss71smwlrk539y9i-mesa-19.3.4/lib/dri)
libGL error: failed to load driver: swrast
[01:06:57:164][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:106: "Use locale: en_US"
[01:06:57:190][0x2220560][Info]:0: "Running app..."
[01:06:57:191][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:170: "Library paths:" ("/gnu/store/zb5xpy07rqs77679hyc2vy6p3cf2wlsr-qttools-5.12.7/lib/qt5/plugins", "/gnu/store/rl999vhbm259c5d5kzzlswsg748n9pwl-qtbase-5.12.7/lib/qt5/plugins", "/gnu/store/7hrwjw25ninmzjwrrhidda7bjvl8ia25-qtdeclarative-5.12.7/lib/qt5/plugins", "/gnu/store/wc6mf038d9rxh5n64ssd7r3475qls33r-qtsvg-5.12.7/lib/qt5/plugins", "/gnu/store/ayrpvjy44bwqsqz3sy5l69y54z6sh6pl-linphoneqt-4.1.1/bin")
[01:06:57:192][0x23116c0][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/components/core/CoreManager.cpp:200: "Launch async linphone core creation."
[01:06:57:197][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:181: "Activated selectors:" ("custom", "en_US", "unix", "linux")
[01:06:57:197][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:355: "Registering types..."
[01:06:57:198][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:389: "Registering shared types..."
[01:06:57:198][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:401: "Registering tool types..."
[01:06:57:198][0x2220560][Info]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/app/App.cpp:409: "Registering shared tool types..."
[01:06:57:203][0x23116c0][Warning]:0: QSocketNotifier: Socket notifiers cannot be enabled or disabled from another thread
[01:06:57:204][0x23116c0][Warning]:0: QMutex: destroying locked mutex


So I've squashed your patches together and rebased them on core-updates,
and made the following modification to register the new patch file:

modified   gnu/local.mk
@@ -1188,6 +1188,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/lierolibre-remove-arch-warning.patch	\
   %D%/packages/patches/lierolibre-try-building-other-arch.patch	\
   %D%/packages/patches/linkchecker-tests-require-network.patch	\
+  %D%/packages/patches/linphoneqt-tabbutton.patch		\
   %D%/packages/patches/linux-libre-support-for-Pinebook-Pro.patch \
   %D%/packages/patches/linux-pam-no-setfsuid.patch		\
   %D%/packages/patches/lirc-localstatedir.patch			\

This is important to not break the Guix package itself.

It seems to work much better now! I need to test it more, but one small
thing I've noticed already: my webcam doesn't seem to be recognized, and
the default ring sound file is not installed:

[01:29:16:690][0x2647190][Warning]/tmp/guix-build-linphoneqt-4.1.1.drv-0/linphoneqt-4.1.1/src/components/sound-player/SoundPlayer.cpp:101:
"Unable to open:
`/gnu/store/9088xmz50p3hy9h5jfi10r1z4gsd59h3-linphoneqt-4.1.1/share/sounds/linphone/rings/notes_of_the_optimistic.mkv`").

Pushed as 45fd28f764 on core-updates.

Thank you for this nice improvement!

Maxim
diff mbox series

Patch

From 6e018522c30cb2a9732ccde98df32118c7699d7f Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 16 Apr 2020 10:26:11 -0400
Subject: [PATCH] gnu: Add linphoneqt.

* gnu/packages/linphone.scm (linphoneqt): New variable.
---
 .../patches/linphoneqt-tabbutton.patch        | 96 +++++++++++++++++++
 1 file changed, 96 insertions(+)
 create mode 100644 gnu/packages/patches/linphoneqt-tabbutton.patch

diff --git a/gnu/packages/patches/linphoneqt-tabbutton.patch b/gnu/packages/patches/linphoneqt-tabbutton.patch
new file mode 100644
index 0000000000..6b3214026e
--- /dev/null
+++ b/gnu/packages/patches/linphoneqt-tabbutton.patch
@@ -0,0 +1,96 @@ 
+From ecaab0f73d0b74bbfbf150286305fa6e12970037 Mon Sep 17 00:00:00 2001
+From: Ronan Abhamon <ronan.abhamon@belledonne-communications.com>
+Date: Fri, 19 Jan 2018 14:42:01 +0100
+Subject: [PATCH] fix(SettingsWindow): rename icon property of TabButton to
+ iconName (issue with Qt 5.10 and new icon property)
+
+---
+ ui/modules/Common/Form/Tab/TabButton.qml |  8 ++++----
+ ui/views/App/Settings/SettingsWindow.qml | 14 +++++++-------
+ 2 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/ui/modules/Common/Form/Tab/TabButton.qml b/ui/modules/Common/Form/Tab/TabButton.qml
+index ad220ab2..a47bb20b 100644
+--- a/ui/modules/Common/Form/Tab/TabButton.qml
++++ b/ui/modules/Common/Form/Tab/TabButton.qml
+@@ -12,8 +12,8 @@ Controls.TabButton {
+ 
+   // ---------------------------------------------------------------------------
+ 
+-  property string icon
+   property int iconSize: TabButtonStyle.icon.size
++  property string iconName
+ 
+   readonly property bool _isSelected: parent.parent.currentItem === button
+ 
+@@ -66,9 +66,9 @@ Controls.TabButton {
+       Layout.leftMargin: TabButtonStyle.text.leftPadding
+ 
+       icon: {
+-        var icon = button.icon
+-        return icon.length
+-          ? (icon + '_' + (button._isSelected ? 'selected' : 'normal'))
++        var iconName = button.iconName
++        return iconName.length
++          ? (iconName + '_' + (button._isSelected ? 'selected' : 'normal'))
+           : ''
+       }
+       iconSize: button.iconSize
+diff --git a/ui/views/App/Settings/SettingsWindow.qml b/ui/views/App/Settings/SettingsWindow.qml
+index b8f5a80f..58909544 100644
+--- a/ui/views/App/Settings/SettingsWindow.qml
++++ b/ui/views/App/Settings/SettingsWindow.qml
+@@ -48,43 +48,43 @@ ApplicationWindow {
+         id: tabBar
+ 
+         TabButton {
+-          icon: 'settings_sip_accounts'
++          iconName: 'settings_sip_accounts'
+           text: qsTr('sipAccountsTab')
+           width: implicitWidth
+         }
+ 
+         TabButton {
+-          icon: 'settings_audio'
++          iconName: 'settings_audio'
+           text: qsTr('audioTab')
+           width: implicitWidth
+         }
+ 
+         TabButton {
+-          icon: 'settings_video'
++          iconName: 'settings_video'
+           text: qsTr('videoTab')
+           width: implicitWidth
+         }
+ 
+         TabButton {
+-          icon: 'settings_call'
++          iconName: 'settings_call'
+           text: qsTr('callsAndChatTab')
+           width: implicitWidth
+         }
+ 
+         TabButton {
+-          icon: 'settings_network'
++          iconName: 'settings_network'
+           text: qsTr('networkTab')
+           width: implicitWidth
+         }
+ 
+         TabButton {
+-          icon: 'settings_advanced'
++          iconName: 'settings_advanced'
+           text: qsTr('uiTab')
+           width: implicitWidth
+         }
+ 
+         TabButton {
+-          icon: 'settings_advanced'
++          iconName: 'settings_advanced'
+           text: qsTr('uiAdvanced')
+           width: implicitWidth
+         }
+-- 
+2.21.0
+
-- 
2.26.0