diff mbox series

[bug#40659] gnu: transmission: Fix icons for GUI.

Message ID 20200416090023.33a422bd.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40659] gnu: transmission: Fix icons for GUI. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 16, 2020, 1 p.m. UTC
Hello Guix!

Please find the attached patch to fix icons for transmission's graphical user
interface.

Regards,
RG.

Comments

Leo Famulari April 16, 2020, 4:21 p.m. UTC | #1
> From 9ab623acb7f70a49f965202c475e18d70e9f8933 Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Thu, 16 Apr 2020 08:57:46 -0400
> Subject: [PATCH] gnu: transmission: Fix icons for GUI.
> 
> * gnu/packages/bittorrent.scm (transmission): Fix icons for GUI.

In general, we let users install the icons into their profiles rather
than propagating them.

Does Transmission work for you if you do that?
Raghav Gururajan April 16, 2020, 4:35 p.m. UTC | #2
Hi Leo!

> In general, we let users install the icons into their profiles rather
> than propagating them.
> 
> Does Transmission work for you if you do that?

Yes, it works.

Anyway, propagation is not reuired. Just as inputs works. Looks like missing
input. I have attached revised patch with this email.

Regards,
RG.
Leo Famulari April 16, 2020, 5:36 p.m. UTC | #3
On Thu, Apr 16, 2020 at 12:35:23PM -0400, Raghav Gururajan wrote:
> Hi Leo!
> 
> > In general, we let users install the icons into their profiles rather
> > than propagating them.
> > 
> > Does Transmission work for you if you do that?
> 
> Yes, it works.

Okay, then I think we should stick with the status quo. We should only
add the icons as dependencies when necessary. Icons are something where
it's better to avoid a static binding, like the time zone database and
fonts.
Raghav Gururajan April 16, 2020, 6:24 p.m. UTC | #4
Hi Leo!

> Okay, then I think we should stick with the status quo. We should only
> add the icons as dependencies when necessary. Icons are something where
> it's better to avoid a static binding, like the time zone database and
> fonts.

I understand.  I think icons should be added as dependencies, when the program
is looking for a 'specific' icon theme. If the situation is like, the program
accepts any user-chosen/user-installed icon theme, then I think icons should
not be added as dependency. But here, transmission is hard-coded to use adwaita
icons. So it is a required dependecy and not optional dependency. :-)

Regards,
RG.
Leo Famulari April 27, 2020, 12:32 a.m. UTC | #5
On Thu, Apr 16, 2020 at 02:24:19PM -0400, Raghav Gururajan wrote:
> I understand.  I think icons should be added as dependencies, when the program
> is looking for a 'specific' icon theme. If the situation is like, the program
> accepts any user-chosen/user-installed icon theme, then I think icons should
> not be added as dependency. But here, transmission is hard-coded to use adwaita
> icons. So it is a required dependecy and not optional dependency. :-)

I don't think that non-functional data (such as icons and fonts) should
be made dependencies of other packages unless necessary. Instead, they
should be installed alongside packages by users or system-level services
as on Guix System.
diff mbox series

Patch

From 9ab623acb7f70a49f965202c475e18d70e9f8933 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 16 Apr 2020 08:57:46 -0400
Subject: [PATCH] gnu: transmission: Fix icons for GUI.

* gnu/packages/bittorrent.scm (transmission): Fix icons for GUI.
---
 gnu/packages/bittorrent.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 03c7fe4515..f71e3be383 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -114,6 +114,8 @@ 
     (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("adwaita-icon-theme" ,adwaita-icon-theme))) ; Required for GUI.
     (home-page "https://transmissionbt.com/")
     (synopsis "Fast and easy BitTorrent client")
     (description
-- 
2.26.0