diff mbox series

[bug#40543,v2,2/5] gnu: python-pyatspi: Propagate python-pygobject.

Message ID 20200415174952.9368-2-mail@cbaines.net
State Accepted
Headers show
Series [bug#40543,v2,1/5] gnu: Add python2-pyatspi. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines April 15, 2020, 5:49 p.m. UTC
As python-pygobject is required at runtime.

* gnu/packages/gnome.scm (python-pygobject)[inputs]: Move python-pygobject to…
[propagated-inputs]: …here.
(python2-pygobject)[inputs]: Move python2-pygobject to…
[propagated-inputs]: …here.
---
 gnu/packages/gnome.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Marius Bakke April 15, 2020, 6:37 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> As python-pygobject is required at runtime.
>
> * gnu/packages/gnome.scm (python-pygobject)[inputs]: Move python-pygobject to…
                                   ^^^
Typo: I think this should be 'python-pyatspi'.

> [propagated-inputs]: …here.
> (python2-pygobject)[inputs]: Move python2-pygobject to…
            ^^^ likewise
> [propagated-inputs]: …here.
> ---
>  gnu/packages/gnome.scm | 10 ++++++----
>  1 file changed, 6 insertions(+), 4 deletions(-)
Christopher Baines April 16, 2020, 8:28 a.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> As python-pygobject is required at runtime.
>>
>> * gnu/packages/gnome.scm (python-pygobject)[inputs]: Move python-pygobject to…
>                                    ^^^
> Typo: I think this should be 'python-pyatspi'.
>
>> [propagated-inputs]: …here.
>> (python2-pygobject)[inputs]: Move python2-pygobject to…
>             ^^^ likewise
>> [propagated-inputs]: …here.
>> ---
>>  gnu/packages/gnome.scm | 10 ++++++----
>>  1 file changed, 6 insertions(+), 4 deletions(-)

Good spot, I've fixed.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4710bd1349..e7b36fff1d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8763,8 +8763,9 @@  from gi.repository import Atspi"))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("python" ,python)
-       ("python-pygobject" ,python-pygobject)))
+     `(("python" ,python)))
+    (propagated-inputs
+     `(("python-pygobject" ,python-pygobject)))
     (synopsis "Python client bindings for D-Bus AT-SPI")
     (home-page "https://wiki.linuxfoundation.org/accessibility\
 /atk/at-spi/at-spi_on_d-bus")
@@ -8779,8 +8780,9 @@  accessibility infrastructure.")
     (inherit python-pyatspi)
     (name "python2-pyatspi")
     (inputs
-     `(("python" ,python-2)
-       ("python-pygobject" ,python2-pygobject)))))
+     `(("python" ,python-2)))
+    (propagated-inputs
+     `(("python-pygobject" ,python2-pygobject)))))
 
 (define-public orca
   (package