diff mbox series

[bug#40646] gnu: Add blueman.

Message ID 20200415135234.3bd638ea.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40646] gnu: Add blueman. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 15, 2020, 5:52 p.m. UTC
Hello Guix!

Please find the attached patch to add 'blueman' package.

Regards,
RG.

Comments

Ludovic Courtès April 19, 2020, 11:22 a.m. UTC | #1
Hi!

Raghav Gururajan <raghavgururajan@disroot.org> skribis:

> From 5f1a319c6b75b3eb28e8f80ea9b31fc5d6cf70df Mon Sep 17 00:00:00 2001
> From: Raghav Gururajan <raghavgururajan@disroot.org>
> Date: Wed, 15 Apr 2020 13:49:55 -0400
> Subject: [PATCH 2/2] gnu: Add blueman.
>
> * gnu/packages/networking.scm (blueman): New variable.

[...]

> +             (substitute* "apps/blueman-adapters.in"
> +               (("@PYTHON@") (string-append (assoc-ref inputs "python")
> +                                            "/bin/python3.7")))

Are you sure this is necessary?  If these are scripts, the
‘patch-shebangs’ phase should take care of it.  Perhaps it’s enough to
add ‘python-wrapper’ as an input (it provides a “python” executable) and
then you can remove all this?

Thanks,
Ludo’.
Raghav Gururajan April 19, 2020, 11:27 a.m. UTC | #2
Hi Ludo!

>> + (substitute* "apps/blueman-adapters.in"
>> + (("@PYTHON@") (string-append (assoc-ref inputs "python")
>> + "/bin/python3.7")))
> 
> Are you sure this is necessary? If these are scripts, the
> ‘patch-shebangs’ phase should take care of it. Perhaps it’s enough to
> add ‘python-wrapper’ as an input (it provides a “python” executable) and
> then you can remove all this?

It is not necessary. Those scripts were not patched by 'patch-shebangs' phase, and received warnings during build. So corrected them manually. :-)

Regards,
RG.
Ludovic Courtès April 19, 2020, 10:21 p.m. UTC | #3
Hi,

"Raghav Gururajan" <raghavgururajan@disroot.org> skribis:

>>> + (substitute* "apps/blueman-adapters.in"
>>> + (("@PYTHON@") (string-append (assoc-ref inputs "python")
>>> + "/bin/python3.7")))
>> 
>> Are you sure this is necessary? If these are scripts, the
>> ‘patch-shebangs’ phase should take care of it. Perhaps it’s enough to
>> add ‘python-wrapper’ as an input (it provides a “python” executable) and
>> then you can remove all this?
>
> It is not necessary. Those scripts were not patched by 'patch-shebangs' phase, and received warnings during build. So corrected them manually. :-)

I think you overlooked the rest of my comment: if you add
‘python-wrapper’ as an input, everything will be fine.

Could you check?

Thanks in advance!

Ludo’.
Raghav Gururajan April 20, 2020, 12:25 a.m. UTC | #4
Hi Ludo!

Yes yes, sorry, I did not over look. I was gonna try it and then goon let you know. :-)

Regards,
RG.

On April 19, 2020 6:21:23 p.m. EDT, "Ludovic Courtès" <ludo@gnu.org> wrote:
>Hi,
>
>"Raghav Gururajan" <raghavgururajan@disroot.org> skribis:
>
>>>> + (substitute* "apps/blueman-adapters.in"
>>>> + (("@PYTHON@") (string-append (assoc-ref inputs "python")
>>>> + "/bin/python3.7")))
>>> 
>>> Are you sure this is necessary? If these are scripts, the
>>> ‘patch-shebangs’ phase should take care of it. Perhaps it’s enough
>to
>>> add ‘python-wrapper’ as an input (it provides a “python” executable)
>and
>>> then you can remove all this?
>>
>> It is not necessary. Those scripts were not patched by
>'patch-shebangs' phase, and received warnings during build. So
>corrected them manually. :-)
>
>I think you overlooked the rest of my comment: if you add
>‘python-wrapper’ as an input, everything will be fine.
>
>Could you check?
>
>Thanks in advance!
>
>Ludo’.
diff mbox series

Patch

From 5f1a319c6b75b3eb28e8f80ea9b31fc5d6cf70df Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 15 Apr 2020 13:49:55 -0400
Subject: [PATCH 2/2] gnu: Add blueman.

* gnu/packages/networking.scm (blueman): New variable.
---
 gnu/packages/networking.scm | 86 +++++++++++++++++++++++++++++++++++++
 1 file changed, 86 insertions(+)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 79b07e23f0..c174911c0a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -105,7 +105,9 @@ 
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages polkit)
   #:use-module (gnu packages pretty-print)
+  #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -122,6 +124,90 @@ 
   #:use-module (gnu packages xml)
   #:use-module (ice-9 match))
 
+(define-public blueman
+  (package
+    (name "blueman")
+    (version "2.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://github.com/blueman-project/blueman/releases/"
+                       "download/2.1.2/blueman-2.1.2.tar.gz"))
+       (sha256
+        (base32 "0wamxdw36c8i3aqwmja5q70fajqwd7inpkvlpkldd54wdxbcd38d"))))
+    (build-system glib-or-gtk-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--enable-polkit"
+        "--disable-appindicator"         ; Deprecated
+        "--with-systemdsystemunitdir=no" ; Not required
+        "--with-systemduserunitdir=no")  ; Not required
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-python-shebangs
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "apps/blueman-adapters.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-applet.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-assistant.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-manager.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-mechanism.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-report.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-rfcomm-watcher.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-sendto.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-services.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             (substitute* "apps/blueman-tray.in"
+               (("@PYTHON@") (string-append (assoc-ref inputs "python")
+                                            "/bin/python3.7")))
+             #t)))))
+    (native-inputs
+     `(("cython" ,python-cython)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("intltool" ,intltool)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("adwaita-icon-theme" ,adwaita-icon-theme)
+       ("bluez" ,bluez)
+       ("dbus" ,dbus)
+       ("gdkpixbuf" ,gdk-pixbuf)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("iproute2" ,iproute)
+       ("net-tools" ,net-tools)
+       ("pango" ,pango)
+       ("polkit" ,polkit)
+       ("pulseaudio" ,pulseaudio)
+       ("pycairo" ,python-pycairo)
+       ("pygobject" ,python-pygobject)
+       ("python" ,python)
+       ("libnm" ,libnma)))
+    (synopsis "GTK+ Bluetooth Manager")
+    (description "Blueman is a bluetooth management utility using bluez dbus
+backend.  It is designed to be easy to use for most common bluetooth tasks.")
+    (home-page "https://github.com/blueman-project/blueman")
+    (license license:gpl3+)))
+
 ;; The gnu.org ‘home’ for this GNU project is a directory listing with 1.6.0 as
 ;; the latest version.  The author's git repository, mentioned in the 1.6.0
 ;; README and otherwise legit-looking, contains a proper 1.7.0 release tarball
-- 
2.26.0