diff mbox series

[bug#40630] gnu: Add udevil.

Message ID 20200414150346.0b070ff8.raghavgururajan@disroot.org
State Accepted
Headers show
Series [bug#40630] gnu: Add udevil. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan April 14, 2020, 7:03 p.m. UTC
Hello Guix!

Please find the attached patch to add 'udevil' package into guix.

Regards,
RG.

Comments

Nicolas Goaziou April 22, 2020, 10:22 p.m. UTC | #1
Hello,

Raghav Gururajan <raghavgururajan@disroot.org> writes:

> Subject: [PATCH] gnu: Add udevil.

Applied as 159e9dce170bc5368248db42722edcfd974b8ad4. Thank you.

> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'patch

I renamed the phase, `phase' being too vague.

> +    (synopsis "Device and File System Manager")

I capitalized the synopsis instead of title case.

> +    (description "udevil is a command line program which mounts and unmounts
> +removable devices without a password, shows device info, and monitors device
> +changes.  It can also mount ISO files, nfs://, smb://, ftp://, ssh:// and WebDAV
> +URLs, and tmpfs/ramfs filesystems.")

I wrote NFS, SMB, FTP, SSH.

Regards,
Raghav Gururajan April 22, 2020, 10:24 p.m. UTC | #2
Hi Nicolas!

> > Subject: [PATCH] gnu: Add udevil.  
> 
> Applied as 159e9dce170bc5368248db42722edcfd974b8ad4. Thank you.
> 
> > +       (modify-phases %standard-phases
> > +         (add-after 'unpack 'patch  
> 
> I renamed the phase, `phase' being too vague.
> 
> > +    (synopsis "Device and File System Manager")  
> 
> I capitalized the synopsis instead of title case.
> 
> > +    (description "udevil is a command line program which mounts and
> > unmounts +removable devices without a password, shows device info, and
> > monitors device +changes.  It can also mount ISO files, nfs://, smb://,
> > ftp://, ssh:// and WebDAV +URLs, and tmpfs/ramfs filesystems.")  
> 
> I wrote NFS, SMB, FTP, SSH.

Thank you very much.

Regards,
RG.
diff mbox series

Patch

From ef9619d878482d4be25cfb97720ef8e616b5487d Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 14 Apr 2020 15:01:43 -0400
Subject: [PATCH] gnu: Add udevil.

* gnu/packages/disk.scm (udevil): New variable.
---
 gnu/packages/disk.scm | 50 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index fb35799e65..27fcf7bb77 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -47,6 +47,7 @@ 
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages elf)
+  #:use-module (gnu packages file-systems)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -64,6 +65,7 @@ 
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages samba)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages swig)
@@ -84,6 +86,54 @@ 
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))
 
+(define-public udevil
+  (package
+    (name "udevil")
+    (version "0.4.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/IgnorantGuru/udevil.git")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0x9mjr9abvbxzfa9mrip5264iz1qxvsl01k3ybz95q4a7xl4jcb3"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+        "--disable-systemd"
+        (string-append "--sysconfdir="
+                       (assoc-ref %outputs "out")
+                       "/etc"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda _
+             (substitute* "src/Makefile.in"
+               (("-o root -g root")
+                ""))
+             #t)))))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("cifs-utils" ,cifs-utils)
+       ("curlftpfs" ,curlftpfs)
+       ("eudev" ,eudev)
+       ("fakeroot" ,fakeroot)
+       ("glib" ,glib)
+       ("sshfs" ,sshfs)))
+    (synopsis "Device and File System Manager")
+    (description "udevil is a command line program which mounts and unmounts
+removable devices without a password, shows device info, and monitors device
+changes.  It can also mount ISO files, nfs://, smb://, ftp://, ssh:// and WebDAV
+URLs, and tmpfs/ramfs filesystems.")
+    (home-page "https://ignorantguru.github.io/udevil/")
+    (license license:gpl3+)))
+
 (define-public parted
   (package
     (name "parted")
-- 
2.26.0