diff mbox series

[bug#40575] gnu: Add python-diceware.

Message ID 20200413215550.21733-1-kraai@ftbfs.org
State Accepted
Headers show
Series [bug#40575] gnu: Add python-diceware. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Matthew James Kraai April 13, 2020, 9:55 p.m. UTC
* gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
variables.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Leo Famulari April 13, 2020, 10:47 p.m. UTC | #1
On Mon, Apr 13, 2020 at 02:55:50PM -0700, Matthew Kraai wrote:
> * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
> variables.

Thanks! Pushed as ab3ad88ded0734401667f6fb4c927ce26c39ad2e
Christopher Baines April 14, 2020, 6:50 p.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Mon, Apr 13, 2020 at 02:55:50PM -0700, Matthew Kraai wrote:
>> * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
>> variables.
>
> Thanks! Pushed as ab3ad88ded0734401667f6fb4c927ce26c39ad2e

Closing the bug now.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ecf7115ab..e089d91979 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,6 +75,7 @@ 
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Matthew Kraai <kraai@ftbfs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19521,3 +19522,27 @@  there are extensions that allow you to use it with other frameworks.")
 register external CLI commands via setuptools entry-points.")
     (home-page "https://github.com/click-contrib/click-plugins")
     (license license:bsd-3)))
+
+(define-public python-diceware
+  (package
+    (name "python-diceware")
+    (version "0.9.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "diceware" version))
+       (sha256
+        (base32
+         "0klb0ysybzlh2wihvir82hgq62v0jjmlcqklwajyms7c0p529yby"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (home-page "https://github.com/ulif/diceware/")
+    (synopsis "Generates memorable passphrases")
+    (description "This package generates passphrases by concatenating words
+randomly picked from wordlists.  It supports several sources of
+randomness (including real life dice) and different wordlists (including
+cryptographically signed ones).")
+    (license license:gpl3+)))