diff mbox series

[bug#40575] gnu: Add python-diceware.

Message ID 20200412150036.6508-1-kraai@ftbfs.org
State Accepted
Headers show
Series [bug#40575] gnu: Add python-diceware. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Matthew James Kraai April 12, 2020, 3 p.m. UTC
* gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
variables.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Leo Famulari April 13, 2020, 9:02 p.m. UTC | #1
On Sun, Apr 12, 2020 at 08:00:36AM -0700, Matthew Kraai wrote:
> * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
> variables.

Thanks! Overall LGTM...

> +(define-public python2-diceware
> +  (package-with-python2 python-diceware))

Do you have a use case for the Python 2 variant? We recently updated our
Python packaging standards to not add these variants unless we need
them:

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=39356057bce20f74120b6d227567a943556717cc
Matthew James Kraai April 13, 2020, 9:50 p.m. UTC | #2
Hi Leo,

On Mon, Apr 13, 2020 at 05:02:09PM -0400, Leo Famulari wrote:
> On Sun, Apr 12, 2020 at 08:00:36AM -0700, Matthew Kraai wrote:
> > * gnu/packages/python-xyz.scm (python-diceware, python2-diceware): New public
> > variables.
> 
> Thanks! Overall LGTM...
> 
> > +(define-public python2-diceware
> > +  (package-with-python2 python-diceware))
> 
> Do you have a use case for the Python 2 variant? We recently updated our
> Python packaging standards to not add these variants unless we need
> them:
> 
> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=39356057bce20f74120b6d227567a943556717cc

No, I don't have a use case for the Python 2 variant.  I'll update the
patch.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ecf7115ab..081bc0eb5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,6 +75,7 @@ 
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
+;;; Copyright © 2020 Matthew Kraai <kraai@ftbfs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19521,3 +19522,30 @@  there are extensions that allow you to use it with other frameworks.")
 register external CLI commands via setuptools entry-points.")
     (home-page "https://github.com/click-contrib/click-plugins")
     (license license:bsd-3)))
+
+(define-public python-diceware
+  (package
+    (name "python-diceware")
+    (version "0.9.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "diceware" version))
+       (sha256
+        (base32
+         "0klb0ysybzlh2wihvir82hgq62v0jjmlcqklwajyms7c0p529yby"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (home-page "https://github.com/ulif/diceware/")
+    (synopsis "Generates memorable passphrases")
+    (description "This package generates passphrases by concatenating words
+randomly picked from wordlists.  It supports several sources of
+randomness (including real life dice) and different wordlists (including
+cryptographically signed ones).")
+    (license license:gpl3+)))
+
+(define-public python2-diceware
+  (package-with-python2 python-diceware))