diff mbox series

[bug#40543,1/4] gnu: Add python2-pyatspi.

Message ID 20200410162157.21065-1-mail@cbaines.net
State Accepted
Headers show
Series Work towards enabling virt-manager tests | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines April 10, 2020, 4:21 p.m. UTC
This will enable updating python2-dogtail to 0.9.11.

* gnu/packages/gnome.scm (python2-pyatspi): New variable.
---
 gnu/packages/gnome.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Marius Bakke April 10, 2020, 4:41 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> This will enable updating python2-dogtail to 0.9.11.
>
> * gnu/packages/gnome.scm (python2-pyatspi): New variable.
> ---
>  gnu/packages/gnome.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 088de7dd4c..b28fe6594b 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -8773,6 +8773,14 @@ accessibility infrastructure.")
>      (license license:lgpl2.0)
>      (properties '((upstream-name . "pyatspi")))))
>  
> +(define-public python2-pyatspi
> +  (package
> +    (inherit python-pyatspi)
> +    (name "python2-pyatspi")
> +    (inputs
> +     `(("python" ,python-2)
> +       ("python-pygobject" ,python2-pygobject)))))

Should the latter not be propagated?  I think the #:python argument of
python-build-system will still refer to python3 in this case.

It's better to use (package-with-python2 ...), see e.g. commit
1ffd618eba4836da5e5eaf6edd394ee949512bd8 for an example.
Christopher Baines April 15, 2020, 5:58 p.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> This will enable updating python2-dogtail to 0.9.11.
>>
>> * gnu/packages/gnome.scm (python2-pyatspi): New variable.
>> ---
>>  gnu/packages/gnome.scm | 8 ++++++++
>>  1 file changed, 8 insertions(+)
>>
>> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> index 088de7dd4c..b28fe6594b 100644
>> --- a/gnu/packages/gnome.scm
>> +++ b/gnu/packages/gnome.scm
>> @@ -8773,6 +8773,14 @@ accessibility infrastructure.")
>>      (license license:lgpl2.0)
>>      (properties '((upstream-name . "pyatspi")))))
>>
>> +(define-public python2-pyatspi
>> +  (package
>> +    (inherit python-pyatspi)
>> +    (name "python2-pyatspi")
>> +    (inputs
>> +     `(("python" ,python-2)
>> +       ("python-pygobject" ,python2-pygobject)))))
>
> Should the latter not be propagated?

Yeah, I've added another commit which makes this propagated.

> I think the #:python argument of python-build-system will still refer
> to python3 in this case.

It would, however python-pyatspi is using the gnu-build-system. I think
this is why I ended up doing it this way.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 088de7dd4c..b28fe6594b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8773,6 +8773,14 @@  accessibility infrastructure.")
     (license license:lgpl2.0)
     (properties '((upstream-name . "pyatspi")))))
 
+(define-public python2-pyatspi
+  (package
+    (inherit python-pyatspi)
+    (name "python2-pyatspi")
+    (inputs
+     `(("python" ,python-2)
+       ("python-pygobject" ,python2-pygobject)))))
+
 (define-public orca
   (package
     (name "orca")