diff mbox series

[bug#40503,staging] gnu: ghc-7: Clean up package definition.

Message ID 20200408102142.3011-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#40503,staging] gnu: ghc-7: Clean up package definition. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka April 8, 2020, 10:21 a.m. UTC
* gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove
  the unused rpath module.
  [phases]: Use invoke instead of system*.
---
 gnu/packages/haskell.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

Comments

Marius Bakke April 8, 2020, 10:38 a.m. UTC | #1
Jakub Kądziołka <kuba@kadziolka.net> writes:

> * gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove
>   the unused rpath module.
>   [phases]: Use invoke instead of system*.

This LGTM, but there have been a few changes to GHC on 'core-updates' so
I'd prefer to hold this patch until core-updates is merged to avoid
needless conflicts.
Maja Kądziołka June 1, 2020, 3:45 p.m. UTC | #2
On Wed, Apr 08, 2020 at 12:38:32PM +0200, Marius Bakke wrote:
> Jakub Kądziołka <kuba@kadziolka.net> writes:
> 
> > * gnu/packages/haskell.scm (ghc-7)[modules, imported-modules]: Remove
> >   the unused rpath module.
> >   [phases]: Use invoke instead of system*.
> 
> This LGTM, but there have been a few changes to GHC on 'core-updates' so
> I'd prefer to hold this patch until core-updates is merged to avoid
> needless conflicts.

Following the core-updates merge, I have committed the change to staging
as commit f20d1cfb51ed14f325da000406807076323f70bc.

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8db650e6ae..40490cbbb6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -183,11 +183,8 @@  top of CLISP.")
 
        #:modules ((guix build gnu-build-system)
                   (guix build utils)
-                  (guix build rpath)
                   (srfi srfi-26)
                   (srfi srfi-1))
-       #:imported-modules (,@%gnu-build-system-modules
-                           (guix build rpath))
        #:configure-flags
        (list
         (string-append "--with-gmp-libraries="
@@ -214,7 +211,7 @@  top of CLISP.")
             (with-directory-excursion ".."
               (copy-file (assoc-ref inputs "ghc-testsuite")
                          "ghc-testsuite.tar.xz")
-              (system* "tar" "xvf" "ghc-testsuite.tar.xz"))
+              (invoke "tar" "xvf" "ghc-testsuite.tar.xz"))
             (substitute*
                 (list "testsuite/timeout/Makefile"
                       "testsuite/timeout/timeout.py"
@@ -233,7 +230,7 @@  top of CLISP.")
              (with-directory-excursion ghc-bootstrap-path
                (copy-file (assoc-ref inputs "ghc-binary")
                           "ghc-bin.tar.xz")
-               (zero? (system* "tar" "xvf" "ghc-bin.tar.xz"))))
+               (invoke "tar" "xvf" "ghc-bin.tar.xz")))
            (alist-cons-before
             'install-bin 'configure-bin
             (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -265,7 +262,7 @@  top of CLISP.")
                   (setenv "LD_LIBRARY_PATH" gmp-lib)
                   ;; The binaries have "/lib64/ld-linux-x86-64.so.2" hardcoded.
                   (for-each
-                   (cut system* "patchelf" "--set-interpreter" ld-so <>)
+                   (cut invoke "patchelf" "--set-interpreter" ld-so <>)
                    binaries)
                   ;; The binaries include a reference to libtinfo.so.5 which
                   ;; is a subset of libncurses.so.5.  We create a symlink in a
@@ -284,7 +281,7 @@  top of CLISP.")
                   (setenv "PATH"
                           (string-append (getenv "PATH") ":"
                                          ghc-bootstrap-prefix "/bin"))
-                  (system*
+                  (invoke
                    (string-append (getcwd) "/configure")
                    (string-append "--prefix=" ghc-bootstrap-prefix)
                    (string-append "--with-gmp-libraries=" gmp-lib)
@@ -294,7 +291,7 @@  top of CLISP.")
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (with-directory-excursion
                    (string-append ghc-bootstrap-path "/ghc-7.8.4")
-                 (zero? (system* "make" "install"))))
+                 (invoke "make" "install")))
              %standard-phases)))))))
     (native-search-paths (list (search-path-specification
                                 (variable "GHC_PACKAGE_PATH")