diff mbox series

[bug#40422,v3] gnu: kmod: Update to 27.

Message ID 20200408071155.22620-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40422,v3] gnu: kmod: Update to 27. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire April 8, 2020, 7:11 a.m. UTC
* gnu/packages/linux.scm (kmod): Update to 27. Enable tests.
---

This patch isn't related with #40274[0] anymore, the “--sysconfdir” flag has
been removed as well as the reverting commit. As discussed in[1] the
configuration of modprobe will be done, in an other patch series, by setting
the “MODPROBE_OPTIONS” varaible in the wrapper returned by
“/proc/sys/kernel/modprobe”.

[0] https://issues.guix.info/issue/40274
[1]: https://lists.gnu.org/archive/html/guix-devel/2020-04/msg00108.html

 gnu/packages/linux.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Danny Milosavljevic April 13, 2020, 11:20 a.m. UTC | #1
Hi Brice,

I get

depmod: WARNING: could not open modules.order at /lib/modules/4.4.4: No such file or directory
depmod: WARNING: could not open modules.builtin at /lib/modules/4.4.4: No such file or directory
depmod: WARNING: could not open modules.order at /lib/modules/4.4.4: No such file or directory
depmod: WARNING: could not open modules.builtin at /lib/modules/4.4.4: No such file or directory
[...]
TESTSUITE: 'depmod_search_order_external_last' [7595] exited with return code 0
TESTSUITE: ERR: sizes do not match /tmp/guix-build-kmod-27.drv-0/kmod-27/testsuite/rootfs/test-depmod/search-order-external-last/lib/modules/4.4.4/correct-modules.dep /tmp/guix-build-kmod-27.drv-0/kmod-27/testsuite/rootfs/test-depmod/search-order-external-last/lib/modules/4.4.4/modules.dep
TESTSUITE: ERR: FAILED: exit ok but outputs do not match: depmod_search_order_external_last
TESTSUITE: ------
FAIL testsuite/test-depmod (exit status: 1)

with your patch on staging...
Brice Waegeneire April 13, 2020, 1:39 p.m. UTC | #2
Hello Danny,

On 2020-04-13 11:20, Danny Milosavljevic wrote:
> Hi Brice,
> 
> I get
> 
> depmod: WARNING: could not open modules.order at /lib/modules/4.4.4:
> No such file or directory
> depmod: WARNING: could not open modules.builtin at /lib/modules/4.4.4:
> No such file or directory
> depmod: WARNING: could not open modules.order at /lib/modules/4.4.4:
> No such file or directory
> depmod: WARNING: could not open modules.builtin at /lib/modules/4.4.4:
> No such file or directory
> [...]
> TESTSUITE: 'depmod_search_order_external_last' [7595] exited with 
> return code 0
> TESTSUITE: ERR: sizes do not match
> /tmp/guix-build-kmod-27.drv-0/kmod-27/testsuite/rootfs/test-depmod/search-order-external-last/lib/modules/4.4.4/correct-modules.dep
> /tmp/guix-build-kmod-27.drv-0/kmod-27/testsuite/rootfs/test-depmod/search-order-external-last/lib/modules/4.4.4/modules.dep
> TESTSUITE: ERR: FAILED: exit ok but outputs do not match:
> depmod_search_order_external_last
> TESTSUITE: ------
> FAIL testsuite/test-depmod (exit status: 1)
> 
> with your patch on staging...

Thanks for the heads up. As written in the Makefile not using
“--sysconfdir=/etc” will make some tests fail, these tests are now 
disable
in v4. BTW this patch should go on core-updates.

Cheers,
- Brice
Brice Waegeneire April 21, 2020, 8:57 a.m. UTC | #3
Ping?
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c8acb42352..386158290f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -42,6 +42,7 @@ 
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2779,7 +2780,7 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
 (define-public kmod
   (package
     (name "kmod")
-    (version "26")
+    (version "27")
     (source (origin
               (method url-fetch)
               (uri
@@ -2787,7 +2788,7 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
                               "kmod-" version ".tar.xz"))
               (sha256
                (base32
-                "17dvrls70nr3b3x1wm8pwbqy4r8a5c20m0dhys8mjhsnpg425fsp"))
+                "035wzfzjx4nwidk747p8n085mgkvy531ppn16krrajx2dkqzply1"))
               (patches (search-patches "kmod-module-directory.patch"))))
     (build-system gnu-build-system)
     (native-inputs
@@ -2796,8 +2797,8 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
      `(("xz" ,xz)
        ("zlib" ,zlib)))
     (arguments
-     `(#:tests? #f                      ; FIXME: Investigate test failures
-       #:configure-flags '("--with-xz" "--with-zlib")
+     `(#:configure-flags '("--with-xz" "--with-zlib"
+                           "--disable-test-modules")
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-modprobe&co