diff mbox series

[bug#40473] gnu: fossil: Update to 2.10.

Message ID 20200406141456.29600-1-jboy@bius.moe
State Accepted
Headers show
Series [bug#40473] gnu: fossil: Update to 2.10. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

John D. Boy April 6, 2020, 2:14 p.m. UTC
* gnu/packages/version-control.scm (fossil): Update to 2.10.
---
 gnu/packages/version-control.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)

Comments

Leo Famulari April 6, 2020, 4:13 p.m. UTC | #1
On Mon, Apr 06, 2020 at 04:14:56PM +0200, John D. Boy wrote:
> * gnu/packages/version-control.scm (fossil): Update to 2.10.

Thanks! I'm testing the build now.

> -       ;; Older downloads are moved to another URL.
> -       (uri (list
> -             (string-append
> -              "https://www.fossil-scm.org/index.html/uv/download/"
> -              "fossil-src-" version ".tar.gz")
> -             (string-append
> +       (uri (string-append
>                "https://www.fossil-scm.org/index.html/uv/"
> -              "fossil-src-" version ".tar.gz")))
> +              "fossil-src-" version ".tar.gz"))

Did they stop using this scheme of serving old tarballs to another
directory?
John D. Boy April 6, 2020, 4:18 p.m. UTC | #2
> Thanks! I'm testing the build now.

Great, thanks!

> > -       ;; Older downloads are moved to another URL.
> > -       (uri (list
> > -             (string-append
> > -              "https://www.fossil-scm.org/index.html/uv/download/"
> > -              "fossil-src-" version ".tar.gz")
> > -             (string-append
> > +       (uri (string-append
> >                "https://www.fossil-scm.org/index.html/uv/"
> > -              "fossil-src-" version ".tar.gz")))
> > +              "fossil-src-" version ".tar.gz"))
> 
> Did they stop using this scheme of serving old tarballs to another
> directory?

Yes, as far as I could tell they are now all in the same hierarchy under /uv.
Leo Famulari April 6, 2020, 4:35 p.m. UTC | #3
On Mon, Apr 06, 2020 at 04:18:07PM +0000, John D. Boy wrote:
> > Did they stop using this scheme of serving old tarballs to another
> > directory?
> 
> Yes, as far as I could tell they are now all in the same hierarchy under /uv.

Okay, pushed as 8a4608b4bf4f13766b4e3d11577c61f398034544
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8af54c6e35..8dc59d0439 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2105,21 +2105,16 @@  by rclone usable with git-annex.")
 (define-public fossil
   (package
     (name "fossil")
-    (version "2.8")
+    (version "2.10")
     (source
      (origin
        (method url-fetch)
-       ;; Older downloads are moved to another URL.
-       (uri (list
-             (string-append
-              "https://www.fossil-scm.org/index.html/uv/download/"
-              "fossil-src-" version ".tar.gz")
-             (string-append
+       (uri (string-append
               "https://www.fossil-scm.org/index.html/uv/"
-              "fossil-src-" version ".tar.gz")))
+              "fossil-src-" version ".tar.gz"))
        (sha256
         (base32
-         "0pbinf8d2kj1j7niblhzjd2l2khg6r2pn2xvig6gavz27p3vwcka"))
+         "041bs4fgk52fw58p7s084pxk9d9vs5v2f2pjbznqawz75inpg8yq"))
        (modules '((guix build utils)))
        (snippet
         '(begin