diff mbox series

[bug#40435,7/7] gnu: rubber: Make some inputs native.

Message ID 20200404174922.11481-7-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#40435,1/7] gnu: gparted: Make some inputs native. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vincent Legoll April 4, 2020, 5:49 p.m. UTC
* gnu/packages/tex.scm (rubber)[inputs]: Move texinfo from here...
[native-inputs]: ...to this new field.
---
 gnu/packages/tex.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e4346d1232..cd461314b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6132,8 +6133,8 @@  other things it comes with full Unicode support.")
                "1xbkv8ll889933gyi2a5hj7hhh216k04gn8fwz5lfv5iz8s34gbq"))))
     (build-system gnu-build-system)
     (arguments '(#:tests? #f))                    ; no `check' target
-    (inputs `(("texinfo" ,texinfo)
-              ("python" ,python-2) ; incompatible with Python 3 (print syntax)
+    (native-inputs `(("texinfo" ,texinfo)))
+    (inputs `(("python" ,python-2) ; incompatible with Python 3 (print syntax)
               ("which" ,which)))
     (home-page "https://launchpad.net/rubber")
     (synopsis "Wrapper for LaTeX and friends")