diff mbox series

[bug#40422] gnu: kmod: Update to 27.

Message ID 20200404071534.17291-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40422] gnu: kmod: Update to 27. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire April 4, 2020, 7:15 a.m. UTC
* gnu/packages/linux.scm (kmod): Update to 27. Enable tests.
---

This patch need to be merge on core-updates because > 2200 packages will need
to be rebuilt.  Without this patch (in particular `--sysconfdir=/etc`) it's
not possible to pass module arguments to `kernel-module-loader` from
<https://issues.guix.info/issue/40274>.

 gnu/packages/linux.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Marius Bakke April 5, 2020, 2:45 p.m. UTC | #1
Brice Waegeneire <brice@waegenei.re> writes:

> * gnu/packages/linux.scm (kmod): Update to 27. Enable tests.
> ---
>
> This patch need to be merge on core-updates because > 2200 packages will need
> to be rebuilt.  Without this patch (in particular `--sysconfdir=/etc`) it's
> not possible to pass module arguments to `kernel-module-loader` from
> <https://issues.guix.info/issue/40274>.

As the core-updates branch is frozen right now, could you submit this
patch as a 'kmod/next' variable?  See e.g. 'help2man/latest' or
'automake-1.16.2' for inspiration.

After the core-updates merge, we can do a larger 'staging' round that
updates the default 'kmod'.

I wonder if we should patch eudev to use
/run/current-system/profile/bin/ instead of /gnu/store/...kmod/bin so
that we can update kmod without triggering a huge rebuild.
Brice Waegeneire April 5, 2020, 3:57 p.m. UTC | #2
On 2020-04-05 14:45, Marius Bakke wrote:
> Brice Waegeneire <brice@waegenei.re> writes:
> 
>> * gnu/packages/linux.scm (kmod): Update to 27. Enable tests.
>> ---
>> 
>> This patch need to be merge on core-updates because > 2200 packages 
>> will need
>> to be rebuilt.  Without this patch (in particular `--sysconfdir=/etc`) 
>> it's
>> not possible to pass module arguments to `kernel-module-loader` from
>> <https://issues.guix.info/issue/40274>.
> 
> As the core-updates branch is frozen right now, could you submit this
> patch as a 'kmod/next' variable?  See e.g. 'help2man/latest' or
> 'automake-1.16.2' for inspiration.

I can do that but I would need to adjust %modprobe-wrapper for
`kernel-loader-module` to work without the crutch at 8c88e24229 since 
the service
gets its modprobe from "/proc/sys/kernel/modprobe".

> After the core-updates merge, we can do a larger 'staging' round that
> updates the default 'kmod'.
> 
> I wonder if we should patch eudev to use
> /run/current-system/profile/bin/ instead of /gnu/store/...kmod/bin so
> that we can update kmod without triggering a huge rebuild.

eudev uses libkmod to to use it's kmod feature so I'm not sure how to do 
this.
Marius Bakke April 5, 2020, 10:14 p.m. UTC | #3
Brice Waegeneire <brice@waegenei.re> writes:

> On 2020-04-05 14:45, Marius Bakke wrote:
>> Brice Waegeneire <brice@waegenei.re> writes:
>> 
>>> * gnu/packages/linux.scm (kmod): Update to 27. Enable tests.
>>> ---
>>> 
>>> This patch need to be merge on core-updates because > 2200 packages 
>>> will need
>>> to be rebuilt.  Without this patch (in particular `--sysconfdir=/etc`) 
>>> it's
>>> not possible to pass module arguments to `kernel-module-loader` from
>>> <https://issues.guix.info/issue/40274>.
>> 
>> As the core-updates branch is frozen right now, could you submit this
>> patch as a 'kmod/next' variable?  See e.g. 'help2man/latest' or
>> 'automake-1.16.2' for inspiration.
>
> I can do that but I would need to adjust %modprobe-wrapper for
> `kernel-loader-module` to work without the crutch at 8c88e24229 since 
> the service
> gets its modprobe from "/proc/sys/kernel/modprobe".

Huh, what kind of sorcery is this?  :-)

Let's hold this patch until core-updates is merged, then I think we can
run it through 'staging'.

>> After the core-updates merge, we can do a larger 'staging' round that
>> updates the default 'kmod'.
>> 
>> I wonder if we should patch eudev to use
>> /run/current-system/profile/bin/ instead of /gnu/store/...kmod/bin so
>> that we can update kmod without triggering a huge rebuild.
>
> eudev uses libkmod to to use it's kmod feature so I'm not sure how to do 
> this.

Oh right, I didn't realize there was a libkmod.
Brice Waegeneire May 10, 2020, 5:22 p.m. UTC | #4
Pushed on staging as 8229ce3116c1f522c7157ab2dcd50dc2d765686a.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 945c15d972..10783c0f5a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -42,6 +42,7 @@ 
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2731,7 +2732,7 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
 (define-public kmod
   (package
     (name "kmod")
-    (version "26")
+    (version "27")
     (source (origin
               (method url-fetch)
               (uri
@@ -2739,7 +2740,7 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
                               "kmod-" version ".tar.xz"))
               (sha256
                (base32
-                "17dvrls70nr3b3x1wm8pwbqy4r8a5c20m0dhys8mjhsnpg425fsp"))
+                "035wzfzjx4nwidk747p8n085mgkvy531ppn16krrajx2dkqzply1"))
               (patches (search-patches "kmod-module-directory.patch"))))
     (build-system gnu-build-system)
     (native-inputs
@@ -2748,8 +2749,8 @@  to use Linux' inotify mechanism, which allows file accesses to be monitored.")
      `(("xz" ,xz)
        ("zlib" ,zlib)))
     (arguments
-     `(#:tests? #f                      ; FIXME: Investigate test failures
-       #:configure-flags '("--with-xz" "--with-zlib")
+     `(#:configure-flags '("--with-xz" "--with-zlib" "--sysconfdir=/etc"
+                           "--disable-test-modules")
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'install-modprobe&co