diff mbox series

[bug#40364,v2] gnu: Add gnome-chess

Message ID 20200401143207.13357-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#40364,v2] gnu: Add gnome-chess | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jack Hill April 1, 2020, 2:32 p.m. UTC
* gnu/packages/games.scm (gnome-chess): New variable.
---

Thanks for the review and suggestion. I've added the #glib-or-gtk? #t
argument, and it looks like the wrapping happens correctly.

 gnu/packages/games.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Christopher Baines April 1, 2020, 5:30 p.m. UTC | #1
Jack Hill <jackhill@jackhill.us> writes:

> * gnu/packages/games.scm (gnome-chess): New variable.
> ---
>
> Thanks for the review and suggestion. I've added the #glib-or-gtk? #t
> argument, and it looks like the wrapping happens correctly.

Great, I've pushed this as 63406c0bfd0d016098ef593dcc8bfc412df36bea.

Thanks for the patch!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e818b851f4..8a24dad33d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -49,6 +49,7 @@ 
 ;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
 ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
 ;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1095,6 +1096,46 @@  destroying an ancient book using a special wand.")
     ;; license.  The whole package is released under GPLv3+.
     (license license:gpl3+)))
 
+(define-public gnome-chess
+  (package
+    (name "gnome-chess")
+    (version "3.36.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version)  "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1a9fgi749gy1f60vbcyrqqkab9vqs42hji70q73k1xx8rv0agmg0"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("librsvg" ,librsvg)))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin") ; for desktop-file-validate and appstream-util
+       ("itstool" ,itstool)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
+    (home-page "https://wiki.gnome.org/Apps/Chess")
+    (synopsis "Chess board for GNOME")
+    (description "GNOME Chess provides a 2D board for playing chess games
+against human or computer players.  It supports loading and saving games in
+Portable Game Notation.  To play against a computer, install a chess engine
+such as chess or stockfish.")
+    (license license:gpl3+)))
+
 (define-public gnubg
   (package
     (name "gnubg")