diff mbox series

[bug#40265,v2] gnu: python-intervaltree: Update to 3.0.2.

Message ID 20200401142448.2683-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#40265,v2] gnu: python-intervaltree: Update to 3.0.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka April 1, 2020, 2:24 p.m. UTC
* gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
[arguments]: Don't skip the tests, work around the problematic
sanity-check instead.
---
Thanks for your helpful comments. I have added a comment, which, in
hindsight, should've been there in the first place :D

I will defer moving the package until committing the new dependent
(pwntools, #40265), as this is best done in a separate commit anyway.

 gnu/packages/bioinformatics.scm | 19 +++++++++++++++----
 1 file changed, 15 insertions(+), 4 deletions(-)

Comments

Marius Bakke April 2, 2020, 3:54 p.m. UTC | #1
Jakub Kądziołka <kuba@kadziolka.net> writes:

> * gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
> [arguments]: Don't skip the tests, work around the problematic
> sanity-check instead.

LGTM.
Maja Kądziołka April 5, 2020, 6:44 p.m. UTC | #2
On Thu, Apr 02, 2020 at 05:54:14PM +0200, Marius Bakke wrote:
> Jakub Kądziołka <kuba@kadziolka.net> writes:
> 
> > * gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
> > [arguments]: Don't skip the tests, work around the problematic
> > sanity-check instead.
> 
> LGTM.

Thanks! Pushed as 7fe746e071e3177e76dad9e2bcd1d53e87187f1a.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d69c2aea63..943369b275 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13552,17 +13553,27 @@  allowing the insertion of arbitrary types into the tree.")
 (define-public python-intervaltree
   (package
     (name "python-intervaltree")
-    (version "2.1.0")
+    (version "3.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "intervaltree" version))
        (sha256
         (base32
-         "02w191m9zxkcjqr1kv2slxvhymwhj3jnsyy3a28b837pi15q19dc"))))
+         "0wz234g6irlm4hivs2qzmnywk0ss06ckagwh15nflkyb3p462kyb"))))
     (build-system python-build-system)
-    ;; FIXME: error when collecting tests
-    (arguments '(#:tests? #f))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; pytest seems to have a check to make sure the user is testing
+         ;; their checked-out code and not an installed, potentially
+         ;; out-of-date copy. This is harmless here, since we just installed
+         ;; the package, so we disable the check to avoid skipping tests
+         ;; entirely.
+         (add-before 'check 'import-mismatch-error-workaround
+           (lambda _
+             (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
+             #t)))))
     (propagated-inputs
      `(("python-sortedcontainers" ,python-sortedcontainers)))
     (native-inputs