diff mbox series

[bug#40360] gnu: gimp: Disable automatic update checking

Message ID 20200331222824.512-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#40360] gnu: gimp: Disable automatic update checking | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jack Hill March 31, 2020, 10:28 p.m. UTC
* gnu/packages/gimp.scm (gimp)[arguments]: Disable update checking in
  #:configure-flags.
---
 gnu/packages/gimp.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

Leo Famulari March 31, 2020, 10:40 p.m. UTC | #1
On Tue, Mar 31, 2020 at 06:28:24PM -0400, Jack Hill wrote:
> * gnu/packages/gimp.scm (gimp)[arguments]: Disable update checking in
>   #:configure-flags.

Thanks! Pushed as a7cc13ed83a356ec50b7dbffdaa91f45ee9d095e
Jack Hill March 31, 2020, 10:45 p.m. UTC | #2
On Tue, 31 Mar 2020, Leo Famulari wrote:

> Thanks! Pushed as a7cc13ed83a356ec50b7dbffdaa91f45ee9d095e

Thanks for the speedy review!
diff mbox series

Patch

diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index fcf613423c..3537fa12f5 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -151,6 +151,9 @@  buffers.")
        (list (string-append "--with-html-dir="
                             (assoc-ref %outputs "doc")
                             "/share/gtk-doc/html")
+             ;; Disable automatic network request on startup to check for
+             ;; version updates.
+             "--disable-check-update"
              ;; ./configure requests not to annoy upstream with packaging bugs.
              "--with-bug-report-url=https://bugs.gnu.org/guix")
        #:phases