diff mbox series

[bug#40281,v2] gnu: Add mtpaint.

Message ID 20200331093956.GA8435@tulip
State Accepted
Headers show
Series [bug#40281,v2] gnu: Add mtpaint. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

R Veera Kumar March 31, 2020, 9:39 a.m. UTC
* gnu/packages/image.scm (mtpaint): New variable.

Signed-off-by: R Veera Kumar <vkor@vkten.in>
---
Changes in v2:
 - Commit msg according to changelog format
 - put gettext in native-inputs
---
 gnu/packages/image.scm | 50 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Ricardo Wurmus April 3, 2020, 4:15 a.m. UTC | #1
R Veera Kumar <vkor@vkten.in> writes:

> * gnu/packages/image.scm (mtpaint): New variable.

Thank you for the patch!

> +
> +(define-public mtpaint
> +  (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
> +        (revision "1"))

Why is this particular commit needed?  Can’t we use the latest release?

> +    (package
> +      (name "mtpaint")
> +      (version (git-version "3.49.25" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/wjaguar/mtPaint/")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
> +      (build-system gnu-build-system)
> +      (native-inputs
> +       `(("gettext" ,gettext-minimal)
> +         ("pkg-config" ,pkg-config)
> +         ("pkg-config" ,pkg-config)

You have this line twice.

> +         ("which" ,which)))
> +      (inputs
> +       `(("imlib2" ,imlib2)
> +         ("libtiff" ,libtiff)
> +         ("libpng" ,libpng)
> +         ("libungif", libungif)
> +         ("libjpeg", libjpeg)
> +         ("libwebp" ,libwebp)
> +         ("openjpeg" ,openjpeg)
> +         ("lcms" ,lcms)
> +         ("zlib", zlib)
> +         ("glib" ,glib)
> +         ("gtk+" ,gtk+-2)))

Could you please build with gtk+ (i.e. version 3).  You probably need to
add “gtk3” to the configure flags.

> +      (arguments
> +       `(#:configure-flags
> +         (list
> +          "intl") ;; internationalized support

Please remove the line break.
For margin comments (at the end of a line) use just one semicolon please.

> +         ;; no check target
> +         #:tests? #f))
> +      (home-page "http://mtpaint.sourceforge.net/")
> +      (synopsis "Create pixel art and manipulate digital images")
> +      (description
> +       "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
> +It can create and edit indexed pallete or 24bit RGB images, offers
> basic

“pallete” –> “palette”

> +painting and palette manipulation tools.

Same here.

--
Ricardo
R Veera Kumar April 3, 2020, 4:42 a.m. UTC | #2
On Fri, Apr 03, 2020 at 06:15:57AM +0200, Ricardo Wurmus wrote:
> 
> R Veera Kumar <vkor@vkten.in> writes:
> 
> > * gnu/packages/image.scm (mtpaint): New variable.
> 
> Thank you for the patch!
> 
> > +
> > +(define-public mtpaint
> > +  (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
> > +        (revision "1"))
> 
> Why is this particular commit needed?  Can’t we use the latest release?
>

The author does not make release tarballs or even make git release tags.
He only puts package version in git commit title.
 
> > +    (package
> > +      (name "mtpaint")
> > +      (version (git-version "3.49.25" revision commit))
> > +      (source
> > +       (origin
> > +         (method git-fetch)
> > +         (uri (git-reference
> > +               (url "https://github.com/wjaguar/mtPaint/")
> > +               (commit commit)))
> > +         (file-name (git-file-name name version))
> > +         (sha256
> > +          (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
> > +      (build-system gnu-build-system)
> > +      (native-inputs
> > +       `(("gettext" ,gettext-minimal)
> > +         ("pkg-config" ,pkg-config)
> > +         ("pkg-config" ,pkg-config)
> 
> You have this line twice.
> 

Will correct this.

> > +         ("which" ,which)))
> > +      (inputs
> > +       `(("imlib2" ,imlib2)
> > +         ("libtiff" ,libtiff)
> > +         ("libpng" ,libpng)
> > +         ("libungif", libungif)
> > +         ("libjpeg", libjpeg)
> > +         ("libwebp" ,libwebp)
> > +         ("openjpeg" ,openjpeg)
> > +         ("lcms" ,lcms)
> > +         ("zlib", zlib)
> > +         ("glib" ,glib)
> > +         ("gtk+" ,gtk+-2)))
> 
> Could you please build with gtk+ (i.e. version 3).  You probably need to
> add “gtk3” to the configure flags.
> 

Currently gtk2 support is stable. gtk3 is testing stage.

> > +      (arguments
> > +       `(#:configure-flags
> > +         (list
> > +          "intl") ;; internationalized support
> 
> Please remove the line break.
> For margin comments (at the end of a line) use just one semicolon please.
> 

Will correct.

> > +         ;; no check target
> > +         #:tests? #f))
> > +      (home-page "http://mtpaint.sourceforge.net/")
> > +      (synopsis "Create pixel art and manipulate digital images")
> > +      (description
> > +       "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
> > +It can create and edit indexed pallete or 24bit RGB images, offers
> > basic
> 
> “pallete” –> “palette”
> 

Will correct.

> > +painting and palette manipulation tools.
> 
> Same here.
> 

Will correct.

R Veera Kumar

> --
> Ricardo
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index cc9cf8cd6a..4946f5a500 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -24,6 +24,7 @@ 
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -45,6 +46,7 @@ 
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages assembly)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages curl)
@@ -1979,3 +1981,51 @@  AOM, including with alpha.")
     (home-page "https://github.com/AOMediaCodec/libavif")
     (license (list license:bsd-2    ; libavif itself
                    license:expat)))) ; cJSON in the test suite
+
+(define-public mtpaint
+  (let ((commit "03b1b0938067b88d86d9f1b1088730f1934d411e")
+        (revision "1"))
+    (package
+      (name "mtpaint")
+      (version (git-version "3.49.25" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/wjaguar/mtPaint/")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0izm2wvj26566fd8mqvypr7bmv7jnq8qhp4760m7z2wrc4y8pjn1"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("gettext" ,gettext-minimal)
+         ("pkg-config" ,pkg-config)
+         ("pkg-config" ,pkg-config)
+         ("which" ,which)))
+      (inputs
+       `(("imlib2" ,imlib2)
+         ("libtiff" ,libtiff)
+         ("libpng" ,libpng)
+         ("libungif", libungif)
+         ("libjpeg", libjpeg)
+         ("libwebp" ,libwebp)
+         ("openjpeg" ,openjpeg)
+         ("lcms" ,lcms)
+         ("zlib", zlib)
+         ("glib" ,glib)
+         ("gtk+" ,gtk+-2)))
+      (arguments
+       `(#:configure-flags
+         (list
+          "intl") ;; internationalized support
+         ;; no check target
+         #:tests? #f))
+      (home-page "http://mtpaint.sourceforge.net/")
+      (synopsis "Create pixel art and manipulate digital images")
+      (description
+       "Mtpaint is a graphic editing program which uses the GTK+ toolkit.
+It can create and edit indexed pallete or 24bit RGB images, offers basic
+painting and palette manipulation tools.  It also handles JPEG, JPEG2000,
+GIF, TIFF, WEBP, BMP, PNG, XPM files.")
+      (license license:gpl3+))))