diff mbox series

[bug#40312,1/3] gnu: Add python-evdev.

Message ID 20200330041651.16348-1-mail@brendan.scot
State Accepted
Headers show
Series [bug#40312,1/3] gnu: Add python-evdev. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Brendan Tildesley March 30, 2020, 4:16 a.m. UTC
* gnu/packages/linux.scm (python-evdev): New variable.
---
 gnu/packages/linux.scm | 42 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 41 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8fec3352f3..0062e1d40f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -28,7 +28,7 @@ 
 ;;; Copyright © 2017 nee <nee-git@hidamari.blue>
 ;;; Copyright © 2017 Dave Love <fx@gnu.org>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
-;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2018, 2020 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2018 Manuel Graf <graf@init.at>
 ;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
@@ -2922,6 +2922,46 @@  time.")
 (define-public eudev-with-hwdb
   (deprecated-package "eudev-with-hwdb" eudev))
 
+(define-public python-evdev
+  (package
+    (name "python-evdev")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "evdev" version))
+       (sha256
+        (base32
+         "0kb3636yaw9l8xi8s184w0r0n9ic5dw3b8hx048jf9fpzss4kimi"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("kernel-headers" ,linux-libre-headers)))
+    (arguments
+     `(#:tests? #f ;; No rule for tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'patch-patch
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "setup.py"
+               (("/usr/include/linux")
+                (string-append
+                 (assoc-ref inputs "kernel-headers") "/include/linux")))
+             #t)))))
+    (home-page
+     "https://python-evdev.readthedocs.io/en/latest/")
+    (synopsis
+     "Bindings to the Linux input handling subsystem")
+    (description
+     "@command{python-evdev} provides bindings to the generic input event
+interface in Linux.  The @command{evdev} interface serves the purpose of
+passing events generated in the kernel directly to userspace through character
+devices that are typically located in @command{/dev/input/}.
+
+This package also comes with bindings to @command{uinput}, the userspace input
+subsystem.  @command{uinput} allows userspace programs to create and handle
+input devices that can inject events directly into the input subsystem.")
+    (license license:bsd-3)))
+
 (define-public lvm2
   (package
     (name "lvm2")