diff mbox series

[bug#40267,2/2] gnu: Add python-pwntools.

Message ID 20200328005345.24506-1-kuba@kadziolka.net
State Under Review
Headers show
Series [bug#40267,1/2] gnu: Add unicorn. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jakub Kądziołka March 28, 2020, 12:53 a.m. UTC
* gnu/packages/cybersecurity.scm (python-pwntools): New variable.
---

This patch requires #40265.

 gnu/packages/cybersecurity.scm | 51 +++++++++++++++++++++++++++++++++-
 1 file changed, 50 insertions(+), 1 deletion(-)

Comments

Leo Famulari March 29, 2020, 2:56 a.m. UTC | #1
On Sat, Mar 28, 2020 at 01:53:45AM +0100, Jakub Kądziołka wrote:
> * gnu/packages/cybersecurity.scm (python-pwntools): New variable.
> +    (propagated-inputs

It would be nice to sort these, especially if the package might grow new
dependencies later.

> +    (license (list license:expat license:bsd-2 license:gpl2+))))

I looked it up; the package is overall MIT/Expat licensed, but a few
components use other licenses. It helpful to list the files with the
other licenses, or to say where to look up the info with a comment like
"See LICENSE-pwntools.txt in the source distribution."
Jakub Kądziołka March 29, 2020, 3:32 p.m. UTC | #2
On Sat, Mar 28, 2020 at 10:56:15PM -0400, Leo Famulari wrote:
> On Sat, Mar 28, 2020 at 01:53:45AM +0100, Jakub Kądziołka wrote:
> > * gnu/packages/cybersecurity.scm (python-pwntools): New variable.
> > +    (propagated-inputs
> 
> It would be nice to sort these, especially if the package might grow new
> dependencies later.

The current order is copied from setup.py in the package, as I felt it
was easier to compare it that way, but I can sort them if that's
preferred.

> > +    (license (list license:expat license:bsd-2 license:gpl2+))))
> 
> I looked it up; the package is overall MIT/Expat licensed, but a few
> components use other licenses. It helpful to list the files with the
> other licenses, or to say where to look up the info with a comment like
> "See LICENSE-pwntools.txt in the source distribution."

Ok, I added your suggested comment locally.
diff mbox series

Patch

diff --git a/gnu/packages/cybersecurity.scm b/gnu/packages/cybersecurity.scm
index aedac03b8a..cb9c33bae1 100644
--- a/gnu/packages/cybersecurity.scm
+++ b/gnu/packages/cybersecurity.scm
@@ -18,10 +18,17 @@ 
 
 (define-module (gnu packages cybersecurity)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system python)
-  #:use-module (gnu packages engineering))
+  #:use-module (gnu packages bioinformatics)
+  #:use-module (gnu packages emulators)
+  #:use-module (gnu packages engineering)
+  #:use-module (gnu packages python-crypto)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages time))
 
 (define-public ropgadget
   (package
@@ -44,3 +51,45 @@ 
 gadgets in binaries.  Some facilities are included for automatically generating
 chains of gadgets to execute system calls.")
     (license license:bsd-3)))
+
+(define-public python-pwntools
+  (package
+    (name "python-pwntools")
+    (version "4.0.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/Gallopsled/pwntools")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "14grsflkfpr7y3gg2lm86lfn6n40yip45n4gjz0hzi9sjalq1gr5"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; Tests require networking and custom sshd configuration
+    (propagated-inputs
+     `(("paramiko" ,python-paramiko)
+       ("mako" ,python-mako)
+       ("pyelftools" ,python-pyelftools)
+       ("capstone" ,python-capstone)
+       ("ropgadget" ,ropgadget)
+       ("pyserial" ,python-pyserial)
+       ("requests" ,python-requests)
+       ("pygments" ,python-pygments)
+       ("pysocks" ,python-pysocks)
+       ("dateutil" ,python-dateutil)
+       ("packaging" ,python-packaging)
+       ("psutil" ,python-psutil)
+       ("intervaltree" ,python-intervaltree)
+       ("sortedcontainers" ,python-sortedcontainers)
+       ("unicorn" ,unicorn-next "python")))
+    (native-inputs
+     `(("tox" ,python-tox)))
+    (home-page "https://github.com/Gallopsled/pwntools")
+    (synopsis "CTF framework and exploit development library")
+    (description "Pwntools is a CTF framework and exploit development library.
+Written in Python, it is designed for rapid prototyping and development, and
+intended to make exploit writing as simple as possible.")
+    (license (list license:expat license:bsd-2 license:gpl2+))))