diff mbox series

[bug#40203,v2] gnu: Add ROPgadget.

Message ID 20200326215529.12389-1-kuba@kadziolka.net
State Accepted
Headers show
Series [bug#40203,v2] gnu: Add ROPgadget. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka March 26, 2020, 9:55 p.m. UTC
* gnu/packages/cybersecurity.scm: New file.
(ropgadget): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Register the file.
---
I have decided to move the package to a separate file. I don't recall
ever doing that before, so I'm sending the package for another,
hopefully quick, round of review.

 gnu/local.mk                   |  1 +
 gnu/packages/cybersecurity.scm | 46 ++++++++++++++++++++++++++++++++++
 2 files changed, 47 insertions(+)
 create mode 100644 gnu/packages/cybersecurity.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 07b159c4fe..0a406dffa0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -138,6 +138,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/cups.scm				\
   %D%/packages/curl.scm				\
   %D%/packages/cvassistant.scm			\
+  %D%/packages/cybersecurity.scm		\
   %D%/packages/cyrus-sasl.scm			\
   %D%/packages/databases.scm			\
   %D%/packages/datamash.scm			\
diff --git a/gnu/packages/cybersecurity.scm b/gnu/packages/cybersecurity.scm
new file mode 100644
index 0000000000..aedac03b8a
--- /dev/null
+++ b/gnu/packages/cybersecurity.scm
@@ -0,0 +1,46 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cybersecurity)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system python)
+  #:use-module (gnu packages engineering))
+
+(define-public ropgadget
+  (package
+    (name "ropgadget")
+    (version "6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ROPGadget" version))
+       (sha256
+        (base32
+         "0idiicgpijar9l9kqmfdh865c2mkfgxg0q7lpz77jc09l6q0afjh"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-capstone" ,python-capstone)))
+    (home-page "http://shell-storm.org/project/ROPgadget/")
+    (synopsis "Semiautomatic return oriented programming")
+    (description
+     "This tool lets you search for @acronym{ROP, Return Oriented Programming}
+gadgets in binaries.  Some facilities are included for automatically generating
+chains of gadgets to execute system calls.")
+    (license license:bsd-3)))