diff mbox series

[bug#40162] gnu: guix-data-service: Update to 0.0.1-19.d12909d.

Message ID 20200326212640.10610-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#40162] gnu: guix-data-service: Update to 0.0.1-19.d12909d. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Christopher Baines March 26, 2020, 9:26 p.m. UTC
These changes support the guix-data-service-backup-database and
guix-data-service-create-small-backup scripts. These are shell scripts, so
require coreutils from the build environment at runtime as well as binaries
from postgresql, ephemeralpg and optionally util-linux (for ionice and
renice).

* gnu/packages/web.scm (guix-data-service): Update to 0.0.1-19.d12909d.
[arguments]: Add (ice-9 ftw) and (ice-9 match) to #:modules, change the
'install phase to wrap all bin files with some inputs as well.
[inputs]: Add util-linux and include ephemeralpg from native-inputs.
[native-inputs]: Move ephemeralpg to inputs.
---
 gnu/packages/web.scm | 35 +++++++++++++++++++++++------------
 1 file changed, 23 insertions(+), 12 deletions(-)

Comments

Ludovic Courtès March 26, 2020, 9:33 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> skribis:

> These changes support the guix-data-service-backup-database and
> guix-data-service-create-small-backup scripts. These are shell scripts, so
> require coreutils from the build environment at runtime as well as binaries
> from postgresql, ephemeralpg and optionally util-linux (for ionice and
> renice).
>
> * gnu/packages/web.scm (guix-data-service): Update to 0.0.1-19.d12909d.
> [arguments]: Add (ice-9 ftw) and (ice-9 match) to #:modules, change the
> 'install phase to wrap all bin files with some inputs as well.
> [inputs]: Add util-linux and include ephemeralpg from native-inputs.
> [native-inputs]: Move ephemeralpg to inputs.

LGTM, thanks!

Ludo'.
Christopher Baines March 26, 2020, 10:53 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Christopher Baines <mail@cbaines.net> skribis:
>
>> These changes support the guix-data-service-backup-database and
>> guix-data-service-create-small-backup scripts. These are shell scripts, so
>> require coreutils from the build environment at runtime as well as binaries
>> from postgresql, ephemeralpg and optionally util-linux (for ionice and
>> renice).
>>
>> * gnu/packages/web.scm (guix-data-service): Update to 0.0.1-19.d12909d.
>> [arguments]: Add (ice-9 ftw) and (ice-9 match) to #:modules, change the
>> 'install phase to wrap all bin files with some inputs as well.
>> [inputs]: Add util-linux and include ephemeralpg from native-inputs.
>> [native-inputs]: Move ephemeralpg to inputs.
>
> LGTM, thanks!

Great, I've pushed this now :)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 10cbf6165b..86d3f41efc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4381,8 +4381,8 @@  CDF, Atom 0.3, and Atom 1.0 feeds.")
   (package-with-python2 python-feedparser))
 
 (define-public guix-data-service
-  (let ((commit "18eb9dfdcb3174bfd4bab5b9089acffa13aa1214")
-        (revision "18"))
+  (let ((commit "d1c243f7fd8902f359ff06fb78dce663cf4297ce")
+        (revision "19"))
     (package
       (name "guix-data-service")
       (version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4394,11 +4394,13 @@  CDF, Atom 0.3, and Atom 1.0 feeds.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0lb78cqzqaz0r4sspg272w2a3yhzhqah30j0kxf0z182b0qpmp37"))))
+                  "1ji8d4vwmv7j9h7z96hvzi3zvik594yngjrdal37w13fbxy2v6sw"))))
       (build-system gnu-build-system)
       (arguments
        '(#:modules ((guix build utils)
                     (guix build gnu-build-system)
+                    (ice-9 ftw)
+                    (ice-9 match)
                     (ice-9 rdelim)
                     (ice-9 popen))
          #:test-target "check-with-tmp-database"
@@ -4426,20 +4428,28 @@  CDF, Atom 0.3, and Atom 1.0 feeds.")
                                           "/site-ccache")))
                  (for-each
                   (lambda (file)
+                    (simple-format (current-error-port)
+                                   "wrapping: ~A\n"
+                                   (string-append bin "/" file))
                     (wrap-program (string-append bin "/" file)
                       `("PATH" ":" prefix
-                        (,bin))
+                        ,(cons*
+                          bin
+                          (map (lambda (input)
+                                 (string-append
+                                  (assoc-ref inputs input)
+                                  "/bin"))
+                               '("ephemeralpg"
+                                 "util-linux"
+                                 "postgresql"))))
                       `("GUILE_LOAD_PATH" ":" prefix
                         (,scm ,(getenv "GUILE_LOAD_PATH")))
                       `("GUILE_LOAD_COMPILED_PATH" ":" prefix
                         (,go ,(getenv "GUILE_LOAD_COMPILED_PATH")))))
-                  '("guix-data-service"
-                    "guix-data-service-process-branch-updated-email"
-                    "guix-data-service-process-branch-updated-mbox"
-                    "guix-data-service-process-job"
-                    "guix-data-service-process-jobs"
-                    "guix-data-service-manage-build-servers"
-                    "guix-data-service-query-build-servers"))
+                  (scandir bin
+                           (match-lambda
+                             ((or "." "..") #f)
+                             (_ #t))))
                  #t)))
            (delete 'strip))))           ; As the .go files aren't compatible
       (inputs
@@ -4448,13 +4458,14 @@  CDF, Atom 0.3, and Atom 1.0 feeds.")
          ("guile-json" ,guile3.0-json)
          ("guile-email" ,guile3.0-email)
          ("guile-squee" ,guile3.0-squee)
+         ("ephemeralpg" ,ephemeralpg)
+         ("util-linux" ,util-linux)
          ("postgresql" ,postgresql)
          ("sqitch" ,sqitch)))
       (native-inputs
        `(("guile" ,guile-3.0)
          ("autoconf" ,autoconf)
          ("automake" ,automake)
-         ("ephemeralpg" ,ephemeralpg)
          ("emacs-minimal" ,emacs-minimal)
          ("emacs-htmlize" ,emacs-htmlize)
          ("pkg-config" ,pkg-config)))