diff mbox series

[bug#39412,v2,3/3] gnu: emacs-telega: Test Emacs environment on startup.

Message ID 20200326131816.26686-1-dnbarbato@posteo.de
State Accepted
Headers show
Series [bug#39412,v2,1/3] gnu: Add emacs-wide-int. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Diego Nicola Barbato March 26, 2020, 1:18 p.m. UTC
Print a more helpful error message when someone attempts to run Telega on an
incompatible Emacs (e.g a 32-bit Emacs without wide ints).

* gnu/packages/patches/telega-test-env.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/emacs-xyz.scm (emacs-telega): Use it.
---
 gnu/local.mk                               |  1 +
 gnu/packages/emacs-xyz.scm                 |  2 ++
 gnu/packages/patches/telega-test-env.patch | 14 ++++++++++++++
 3 files changed, 17 insertions(+)
 create mode 100644 gnu/packages/patches/telega-test-env.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 7cce60b7c0..eb6998cb65 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1448,6 +1448,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/tcsh-fix-autotest.patch			\
   %D%/packages/patches/tcsh-fix-out-of-bounds-read.patch	\
   %D%/packages/patches/teensy-loader-cli-help.patch		\
+  %D%/packages/patches/telega-test-env.patch			\
   %D%/packages/patches/texinfo-5-perl-compat.patch		\
   %D%/packages/patches/texlive-bin-CVE-2018-17407.patch		\
   %D%/packages/patches/texlive-bin-luatex-poppler-compat.patch	\
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 401dbdec2c..23a988625d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20580,6 +20580,8 @@  fish-completion.  It can be used in both Eshell and M-x shell.")
          (sha256
           (base32
            "0mv6i80958d9crzspzik5xh5g8326115bvg2frgv0dp9p6rm86m3"))
+         (patches
+          (search-patches "telega-test-env.patch"))
          (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
diff --git a/gnu/packages/patches/telega-test-env.patch b/gnu/packages/patches/telega-test-env.patch
new file mode 100644
index 0000000000..7b2600d13b
--- /dev/null
+++ b/gnu/packages/patches/telega-test-env.patch
@@ -0,0 +1,14 @@ 
+Test Emacs environment on startup.
+
+Patch by Diego N. Barbato
+
+--- a/telega.el	2020-02-07 17:07:18.549970090 +0100
++++ b/telega.el	2020-02-07 17:10:08.383499765 +0100
+@@ -82,6 +82,7 @@
+   "Start telegramming.
+ If prefix ARG is given, then will not pop to telega root buffer."
+   (interactive "P")
++  (telega-test-env)
+   (telega--create-hier)
+ 
+   (unless (telega-server-live-p)