diff mbox series

[bug#40209] gnu: qiv: Add new pkg qiv an image viewer for X

Message ID 20200324103316.GA3324@tulip
State Accepted
Headers show
Series [bug#40209] gnu: qiv: Add new pkg qiv an image viewer for X | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

R Veera Kumar March 24, 2020, 10:33 a.m. UTC
Add qiv an image viewer for X.

Signed-off-by: R Veera Kumar <vkor@vkten.in>
---
 gnu/packages/qiv.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)
 create mode 100644 gnu/packages/qiv.scm

Comments

Danny Milosavljevic March 24, 2020, 12:04 p.m. UTC | #1
Hi Veera,

in order to make this actually work in a Guix release, please refer to the new
file in gnu/local.mk in GNU_SYSTEM_MODULES .

Or better yet, in this case I would prefer if you just added qiv to the existing
file gnu/packages/image-viewers.scm .

>+       #:tests? #f

Why?  Please add a comment.

It seems that the changelog mentions that the tests are now in "make install".
Did the tests work?

>+       #:make-flags
>+        (list
>+          "CC=gcc"
>+          "LCMS="
>+          (string-append "PREFIX=" (assoc-ref %outputs "out")))))

Indentation is off.

Otherwise it looks good.

Could you send a v2 of your patch with these points addressed?
diff mbox series

Patch

diff --git a/gnu/packages/qiv.scm b/gnu/packages/qiv.scm
new file mode 100644
index 0000000000..76b3c5702c
--- /dev/null
+++ b/gnu/packages/qiv.scm
@@ -0,0 +1,53 @@ 
+(define-module (gnu packages qiv)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages photo)
+  #:use-module (gnu packages pkg-config))
+
+
+(define-public qiv
+  (package
+    (name "qiv")
+    (version "2.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://spiegl.de/qiv/download/qiv-"
+                           version ".tgz"))
+       (sha256
+        (base32 "1rlf5h67vhj7n1y7jqkm9k115nfnzpwngj3kzqsi2lg676srclv7"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("imlib2" ,imlib2)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+-2)
+       ("libtiff" ,libtiff)
+       ("libexif" ,libexif)
+       ("libpng" ,libpng)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete `configure))
+       #:tests? #f
+       #:make-flags
+        (list
+          "CC=gcc"
+          "LCMS="
+          (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+    (home-page "http://spiegl.de/qiv/")
+    (synopsis "Graphical image viewer for X")
+    (description
+      "Quick Image Viewer is a very small and fast GDK/Imlib image viewer.
+Features include zoom, maxpect, scale down, fullscreen, brightness/contrast/
+gamma correction, slideshow, pan with keyboard and mouse, rotate left/right,
+flip, delete, jump/forward/backward images, filename filter and use it to
+set X desktop background.")
+    (license license:gpl2)))