diff mbox series

[bug#33753,1/3] gnu: Add sbcl-clx-truetype.

Message ID 20200323072442.25966-1-go.wigust@gmail.com
State Accepted
Headers show
Series ttf-fonts module in StumpWM | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Oleg Pykhalov March 23, 2020, 7:24 a.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-clx-truetype): New variable.
---
 gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Guillaume Le Vaillant March 23, 2020, 9:06 a.m. UTC | #1
Oleg Pykhalov <go.wigust@gmail.com> skribis:

> * gnu/packages/lisp-xyz.scm (sbcl-clx-truetype): New variable.

The author of clx-truetype suggests using truetype-clx instead (see
https://github.com/quicklisp/quicklisp-projects/issues/1774). Have you
checked if that would work for the ttf-fonts module of stumpwm-contrib?

If not, maybe we could get the sources from a fork of the original
repository that disappeared instead of fetching the Quicklisp archive
(for example, https://github.com/l04m33/clx-truetype has clx-truetype
version 0.1).
Oleg Pykhalov March 30, 2020, 8:24 p.m. UTC | #2
Hi,

Apologies for a delay.

Guillaume Le Vaillant <glv@posteo.net> writes:

> The author of clx-truetype suggests using truetype-clx instead (see
> https://github.com/quicklisp/quicklisp-projects/issues/1774). Have you
> checked if that would work for the ttf-fonts module of stumpwm-contrib?
>
> If not, maybe we could get the sources from a fork of the original
> repository that disappeared instead of fetching the Quicklisp archive
> (for example, https://github.com/l04m33/clx-truetype has clx-truetype
> version 0.1).

I've tested in a VM, it works.  Thank you for noticing this!

Also I pushed stumpish package in addition to this series. 

Regards,
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 043c219e5e..d0af123171 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
 ;;; Copyright © 2020 Dimakis Dimakakos <me@bendersteed.tech>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -619,6 +620,40 @@  from other CLXes around the net.")
 (define-public ecl-clx
   (sbcl-package->ecl-package sbcl-clx))
 
+(define-public sbcl-clx-truetype
+  (package
+    (name "sbcl-clx-truetype")
+    (version "2016-08-25")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://beta.quicklisp.org/archive/clx-truetype/" version
+             "/clx-truetype-" (string-delete #\- version) "-git.tgz"))
+       (sha256
+        (base32
+         "0ndy067rg9w6636gxwlpnw7f3ck9nrnjb03444pprik9r3c9in67"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (substitute* "package.lisp"
+             ((":export") ":export\n   :+font-cache-filename+"))
+           #t))))
+    (build-system asdf-build-system/sbcl)
+    (inputs
+     `(("clx" ,sbcl-clx)
+       ("zpb-ttf" ,sbcl-zpb-ttf)
+       ("cl-vectors" ,sbcl-cl-vectors)
+       ("cl-paths-ttf" ,sbcl-cl-paths-ttf)
+       ("cl-fad" ,sbcl-cl-fad)
+       ("cl-store" ,sbcl-cl-store)
+       ("trivial-features" ,sbcl-trivial-features)))
+    (home-page "http://beta.quicklisp.org/archive/clx-truetype/")
+    (synopsis "Antialiased TrueType font rendering using CLX and XRender")
+    (description "CLX-TrueType is pure common lisp solution for
+antialiased TrueType font rendering using CLX and XRender extension.")
+    (license license:expat)))
+
 (define-public sbcl-cl-ppcre-unicode
   (package (inherit sbcl-cl-ppcre)
     (name "sbcl-cl-ppcre-unicode")