diff mbox series

[bug#40143] gnu: git: Return #t in install-man-pages phase.

Message ID 20200320092005.22388-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40143] gnu: git: Return #t in install-man-pages phase. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire March 20, 2020, 9:20 a.m. UTC
* gnu/packages/version-control.scm (git)[arguments]: Return #t in
install-man-pages phase.
---
 gnu/packages/version-control.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


base-commit: 837644b48a5107a28acbdb6d172aff0040a8247d
prerequisite-patch-id: b9e1cb7e09e15cac4d607e985e2a3b5e301828e5
prerequisite-patch-id: e22ea3f99fc3d9f3e11ddfa31ba60212f2ed4d62

Comments

Danny Milosavljevic March 20, 2020, 9:54 a.m. UTC | #1
invoke already returns #t, so there's no technical bug.

That said, maybe for clarity?  Not sure...
Maxim Cournoyer March 20, 2020, 2:21 p.m. UTC | #2
Danny Milosavljevic <dannym@scratchpost.org> writes:

> invoke already returns #t, so there's no technical bug.
>
> That said, maybe for clarity?  Not sure...

I don't see any technical nor clarity issue here.  The vision laid out
by Mark more than two years ago (!) was to get rid of all the boolean
return codes and move to an exception based system entirely, which I
find much more elegant.  The transition plan was outlined in this
message:
https://lists.gnu.org/archive/html/guix-devel/2017-12/msg00278.html.

I think we should go back to work on finishing the missing bits :-).

Maxim
Mathieu Othacehe March 21, 2020, 2:29 p.m. UTC | #3
Hello Brice,

> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
>> invoke already returns #t, so there's no technical bug.
>>
>> That said, maybe for clarity?  Not sure...

I agree with Danny and Maxim here, we already return a boolean, or
raise an exception in case of error, so I think we are fine :)

Closing this bug,

Thanks,

Mathieu
Brice Waegeneire March 21, 2020, 2:43 p.m. UTC | #4
On 2020-03-21 14:29, Mathieu Othacehe wrote:
> Hello Brice,
> 
>> Danny Milosavljevic <dannym@scratchpost.org> writes:
>> 
>>> invoke already returns #t, so there's no technical bug.
>>> 
>>> That said, maybe for clarity?  Not sure...
> 
> I agree with Danny and Maxim here, we already return a boolean, or
> raise an exception in case of error, so I think we are fine :)
> 
> Closing this bug,
> 
> Thanks,
> 
> Mathieu

Looks like a forgot to reply to all, I replied to Danny that it
should be closed. I missed the RTFM sign... I didn't knew about
Maxim's link and would like to know where are we in transitioning
away from getting rid of boolean return code in phases.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d25df4c63d..7eb85cc749 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -441,7 +441,8 @@  as well as the classic centralized workflow.")
                    (manpages (assoc-ref inputs "git-manpages")))
               (mkdir-p man)
               (with-directory-excursion man
-                (invoke "tar" "xvf" manpages))))))))
+                (invoke "tar" "xvf" manpages)))
+            #t)))))
 
    (native-search-paths
     ;; For HTTPS access, Git needs a single-file certificate bundle, specified