diff mbox series

[bug#40129] gnu: gpa: Add phase wrap-program.

Message ID 20200319091937.11811-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40129] gnu: gpa: Add phase wrap-program. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire March 19, 2020, 9:19 a.m. UTC
Fixes <https://bugs.gnu.org/36109>

* gnu/packages/gnupg.scm (gpa)[arguments]: Add phase wrap-program.
---
 gnu/packages/gnupg.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)


base-commit: 771c5e155d7862ed91a5d503eecc00c1db1150ad

Comments

Marius Bakke March 19, 2020, 9:51 a.m. UTC | #1
Brice Waegeneire <brice@waegenei.re> writes:

> Fixes <https://bugs.gnu.org/36109>
>
> * gnu/packages/gnupg.scm (gpa)[arguments]: Add phase wrap-program.

Applied, thanks!

[...]

> +         (add-after 'install 'wrap-program
> +           (lambda* (#:key inputs outputs #:allow-other-keys)
> +             (let ((out (assoc-ref outputs "out"))
> +                   (gnupg (assoc-ref inputs "gnupg")))
> +               (wrap-program (string-append out "/bin/gpa")
> +                 `("PATH" ":" prefix (,(string-append gnupg "/bin")))
> +                 )))))))

I ended this phase on a #t and fixed the lonely parens as reported by
'guix lint gpa'.
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index c5c3d5263f..30658c7cb7 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -975,6 +975,16 @@  however, pgpdump produces more detailed and easier to understand output.")
                (base32
                 "1cbpc45f8qbdkd62p12s3q2rdq6fa5xdzwmcwd3xrj55bzkspnwm"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (gnupg (assoc-ref inputs "gnupg")))
+               (wrap-program (string-append out "/bin/gpa")
+                 `("PATH" ":" prefix (,(string-append gnupg "/bin")))
+                 )))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs